[prev in list] [next in list] [prev in thread] [next in thread] 

List:       calligra-devel
Subject:    Re: Review Request 119496: Log explicitely why a product was dropped
From:       "Elvis Stansvik" <elvstone () gmail ! com>
Date:       2014-07-27 17:46:17
Message-ID: 20140727174617.15443.5380 () probe ! kde ! org
[Download RAW message or body]

--===============6448841181282157174==
MIME-Version: 1.0
Content-Type: text/plain; charset="utf-8"
Content-Transfer-Encoding: 7bit



> On July 27, 2014, 4:10 p.m., Elvis Stansvik wrote:
> > cmake/modules/CalligraProductSetMacros.cmake, line 37
> > <https://git.reviewboard.kde.org/r/119496/diff/1/?file=293440#file293440line37>
> > 
> > is this necessary? it just unsets ${_current_flag} right? (which has never been \
> > set at this point).
> 
> Friedrich W. H. Kossebau wrote:
> Not necessary right now, yes. But it is done to protect against any other code \
> starting to use a var with that very name. Sadly there seems no way to limit the \
> scope of vars to functions in CMake 2.x (AFAIK).

Ah. Then it makes sense.


> On July 27, 2014, 4:10 p.m., Elvis Stansvik wrote:
> > cmake/modules/CalligraProductSetMacros.cmake, line 43
> > <https://git.reviewboard.kde.org/r/119496/diff/1/?file=293440#file293440line43>
> > 
> > maybe use unset(..) instead? it's a little clearer i think. at least i had to \
> > consult the cmake docs to realize set(..) actually unsets when no value is passed \
> > in :)
> 
> Friedrich W. H. Kossebau wrote:
> unset() might be better to use, yes, good hint. Did not know it exists and got used \
> to set() already :) Will keep in mind and the next weeks prepare a cleanup patch \
> for all those cases were unset() could be used instead of set() (unless someone \
> beats me to it ;) )

Here you go: https://git.reviewboard.kde.org/r/119502/ :)


- Elvis


-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://git.reviewboard.kde.org/r/119496/#review63263
-----------------------------------------------------------


On July 27, 2014, 3:55 p.m., Friedrich W. H. Kossebau wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://git.reviewboard.kde.org/r/119496/
> -----------------------------------------------------------
> 
> (Updated July 27, 2014, 3:55 p.m.)
> 
> 
> Review request for Calligra.
> 
> 
> Repository: calligra
> 
> 
> Description
> -------
> 
> The current build system is slightly unprecise about which external dep is missing, \
> there is only one generic string for each product if one or more of the external \
> deps was/were missing. E.g. "libodfgen|libetonyek|librevenge devel not found" or \
> "SharedMimeInfo|libeigen3|libexiv2|lcms|boost-system devel not found". 
> This patch changes that by adding a new macro \
> "calligra_drop_product_on_bad_condition" and adapting the current \
> product-dropping-due-to-bad-external-deps code. As side effect it gives a nice \
> listing of external deps for each product. 
> Any better name for "calligra_drop_product_on_bad_condition"?
> 
> (Also brings consistent handling of Xinput_FOUND as TRUE for Windows and OSX)
> 
> 
> Diffs
> -----
> 
> CMakeLists.txt f76746c 
> cmake/modules/CalligraProductSetMacros.cmake bdca16c 
> 
> Diff: https://git.reviewboard.kde.org/r/119496/diff/
> 
> 
> Testing
> -------
> 
> 
> Thanks,
> 
> Friedrich W. H. Kossebau
> 
> 


--===============6448841181282157174==
MIME-Version: 1.0
Content-Type: text/html; charset="utf-8"
Content-Transfer-Encoding: 7bit




<html>
 <body>
  <div style="font-family: Verdana, Arial, Helvetica, Sans-Serif;">
   <table bgcolor="#f9f3c9" width="100%" cellpadding="12" style="border: 1px #c9c399 \
solid; border-radius: 6px; -moz-border-radius: 6px; -webkit-border-radius: 6px;">  \
<tr>  <td>
      This is an automatically generated e-mail. To reply, visit:
      <a href="https://git.reviewboard.kde.org/r/119496/">https://git.reviewboard.kde.org/r/119496/</a>
  </td>
    </tr>
   </table>
   <br />










<blockquote style="margin-left: 1em; border-left: 2px solid #d0d0d0; padding-left: \
10px;">  <p style="margin-top: 0;">On July 27th, 2014, 4:10 p.m. UTC, <b>Elvis \
Stansvik</b> wrote:</p>  <blockquote style="margin-left: 1em; border-left: 2px solid \
#d0d0d0; padding-left: 10px;">  


<table width="100%" border="0" bgcolor="white" style="border: 1px solid #C0C0C0; \
border-collapse: collapse; margin: 2px padding: 2px;">  <thead>
  <tr>
   <th colspan="4" bgcolor="#F0F0F0" style="border-bottom: 1px solid #C0C0C0; \
font-size: 9pt; padding: 4px 8px; text-align: left;">  <a \
href="https://git.reviewboard.kde.org/r/119496/diff/1/?file=293440#file293440line37" \
style="color: black; font-weight: bold; text-decoration: \
underline;">cmake/modules/CalligraProductSetMacros.cmake</a>  <span \
style="font-weight: normal;">

     (Diff revision 1)

    </span>
   </th>
  </tr>
 </thead>



 
 

 <tbody>

  <tr>
    <th bgcolor="#b1ebb0" style="border-right: 1px solid #C0C0C0;" \
align="right"><font size="2"></font></th>  <td bgcolor="#c5ffc4" width="50%"><pre \
style="font-size: 8pt; line-height: 140%; margin: 0; "></pre></td>  <th \
bgcolor="#b1ebb0" style="border-left: 1px solid #C0C0C0; border-right: 1px solid \
#C0C0C0;" align="right"><font size="2">37</font></th>  <td bgcolor="#c5ffc4" \
width="50%"><pre style="font-size: 8pt; line-height: 140%; margin: 0; ">  <span \
class="nb">set</span><span class="p">(</span><span \
class="s">_current_flag</span><span class="p">)</span></pre></td>  </tr>

 </tbody>

</table>

  <pre style="white-space: pre-wrap; white-space: -moz-pre-wrap; white-space: \
-pre-wrap; white-space: -o-pre-wrap; word-wrap: break-word;"><p style="padding: \
0;text-rendering: inherit;margin: 0;line-height: inherit;white-space: inherit;">is \
this necessary? it just unsets ${_current_flag} right? (which has never been set at \
this point).</p></pre>  </blockquote>



 <p>On July 27th, 2014, 4:25 p.m. UTC, <b>Friedrich W. H. Kossebau</b> wrote:</p>
 <blockquote style="margin-left: 1em; border-left: 2px solid #d0d0d0; padding-left: \
10px;">  <pre style="white-space: pre-wrap; white-space: -moz-pre-wrap; white-space: \
-pre-wrap; white-space: -o-pre-wrap; word-wrap: break-word;"><p style="padding: \
0;text-rendering: inherit;margin: 0;line-height: inherit;white-space: inherit;">Not \
necessary right now, yes. But it is done to protect against any other code starting \
to use a var with that very name. Sadly there seems no way to limit the scope of vars \
to functions in CMake 2.x (AFAIK).</p></pre>  </blockquote>







</blockquote>
<pre style="margin-left: 1em; white-space: pre-wrap; white-space: -moz-pre-wrap; \
white-space: -pre-wrap; white-space: -o-pre-wrap; word-wrap: break-word;"><p \
style="padding: 0;text-rendering: inherit;margin: 0;line-height: inherit;white-space: \
inherit;">Ah. Then it makes sense.</p></pre> <br />

<blockquote style="margin-left: 1em; border-left: 2px solid #d0d0d0; padding-left: \
10px;">  <p style="margin-top: 0;">On July 27th, 2014, 4:10 p.m. UTC, <b>Elvis \
Stansvik</b> wrote:</p>  <blockquote style="margin-left: 1em; border-left: 2px solid \
#d0d0d0; padding-left: 10px;">  


<table width="100%" border="0" bgcolor="white" style="border: 1px solid #C0C0C0; \
border-collapse: collapse; margin: 2px padding: 2px;">  <thead>
  <tr>
   <th colspan="4" bgcolor="#F0F0F0" style="border-bottom: 1px solid #C0C0C0; \
font-size: 9pt; padding: 4px 8px; text-align: left;">  <a \
href="https://git.reviewboard.kde.org/r/119496/diff/1/?file=293440#file293440line43" \
style="color: black; font-weight: bold; text-decoration: \
underline;">cmake/modules/CalligraProductSetMacros.cmake</a>  <span \
style="font-weight: normal;">

     (Diff revision 1)

    </span>
   </th>
  </tr>
 </thead>



 
 

 <tbody>

  <tr>
    <th bgcolor="#b1ebb0" style="border-right: 1px solid #C0C0C0;" \
align="right"><font size="2"></font></th>  <td bgcolor="#c5ffc4" width="50%"><pre \
style="font-size: 8pt; line-height: 140%; margin: 0; "></pre></td>  <th \
bgcolor="#b1ebb0" style="border-left: 1px solid #C0C0C0; border-right: 1px solid \
#C0C0C0;" align="right"><font size="2">43</font></th>  <td bgcolor="#c5ffc4" \
width="50%"><pre style="font-size: 8pt; line-height: 140%; margin: 0; ">      <span \
class="nb">set</span><span class="p">(</span><span \
class="s">_current_flag</span><span class="p">)</span></pre></td>  </tr>

 </tbody>

</table>

  <pre style="white-space: pre-wrap; white-space: -moz-pre-wrap; white-space: \
-pre-wrap; white-space: -o-pre-wrap; word-wrap: break-word;"><p style="padding: \
0;text-rendering: inherit;margin: 0;line-height: inherit;white-space: inherit;">maybe \
use unset(..) instead? it's a little clearer i think. at least i had to consult the \
cmake docs to realize set(..) actually unsets when no value is passed in :)</p></pre> \
</blockquote>



 <p>On July 27th, 2014, 4:25 p.m. UTC, <b>Friedrich W. H. Kossebau</b> wrote:</p>
 <blockquote style="margin-left: 1em; border-left: 2px solid #d0d0d0; padding-left: \
10px;">  <pre style="white-space: pre-wrap; white-space: -moz-pre-wrap; white-space: \
-pre-wrap; white-space: -o-pre-wrap; word-wrap: break-word;"><p style="padding: \
0;text-rendering: inherit;margin: 0;line-height: inherit;white-space: \
inherit;">unset() might be better to use, yes, good hint. Did not know it exists and \
got used to set() already :)<br style="padding: 0;text-rendering: inherit;margin: \
0;line-height: inherit;white-space: normal;" /> Will keep in mind and the next weeks \
prepare a cleanup patch for all those cases were unset() could be used instead of \
set() (unless someone beats me to it ;) )</p></pre>  </blockquote>







</blockquote>
<pre style="margin-left: 1em; white-space: pre-wrap; white-space: -moz-pre-wrap; \
white-space: -pre-wrap; white-space: -o-pre-wrap; word-wrap: break-word;"><p \
style="padding: 0;text-rendering: inherit;margin: 0;line-height: inherit;white-space: \
inherit;">Here you go: https://git.reviewboard.kde.org/r/119502/ :)</p></pre> <br />




<p>- Elvis</p>


<br />
<p>On July 27th, 2014, 3:55 p.m. UTC, Friedrich W. H. Kossebau wrote:</p>









<table bgcolor="#fefadf" width="100%" cellspacing="0" cellpadding="12" style="border: \
1px #888a85 solid; border-radius: 6px; -moz-border-radius: 6px; \
-webkit-border-radius: 6px;">  <tr>
  <td>

<div>Review request for Calligra.</div>
<div>By Friedrich W. H. Kossebau.</div>


<p style="color: grey;"><i>Updated July 27, 2014, 3:55 p.m.</i></p>









<div style="margin-top: 1.5em;">
 <b style="color: #575012; font-size: 10pt;">Repository: </b>
calligra
</div>


<h1 style="color: #575012; font-size: 10pt; margin-top: 1.5em;">Description </h1>
 <table width="100%" bgcolor="#ffffff" cellspacing="0" cellpadding="10" \
style="border: 1px solid #b8b5a0">  <tr>
  <td>
   <pre style="margin: 0; padding: 0; white-space: pre-wrap; white-space: \
-moz-pre-wrap; white-space: -pre-wrap; white-space: -o-pre-wrap; word-wrap: \
break-word;"><p style="padding: 0;text-rendering: inherit;margin: 0;line-height: \
inherit;white-space: inherit;">The current build system is slightly unprecise about \
which external dep is missing, there is only one generic string for each product if \
one or more of the external deps was/were missing. E.g. \
"libodfgen|libetonyek|librevenge devel not found" or \
"SharedMimeInfo|libeigen3|libexiv2|lcms|boost-system devel not found".</p> <p \
style="padding: 0;text-rendering: inherit;margin: 0;line-height: inherit;white-space: \
inherit;">This patch changes that by adding a new macro \
"calligra_drop_product_on_bad_condition" and adapting the current \
product-dropping-due-to-bad-external-deps code. As side effect it gives a nice \
listing of external deps for each product.</p> <p style="padding: 0;text-rendering: \
inherit;margin: 0;line-height: inherit;white-space: inherit;">Any better name for \
"calligra_drop_product_on_bad_condition"?</p> <p style="padding: 0;text-rendering: \
inherit;margin: 0;line-height: inherit;white-space: inherit;">(Also brings consistent \
handling of Xinput_FOUND as TRUE for Windows and OSX)</p></pre>  </td>
 </tr>
</table>



<h1 style="color: #575012; font-size: 10pt; margin-top: 1.5em;">Diffs</b> </h1>
<ul style="margin-left: 3em; padding-left: 0;">

 <li>CMakeLists.txt <span style="color: grey">(f76746c)</span></li>

 <li>cmake/modules/CalligraProductSetMacros.cmake <span style="color: \
grey">(bdca16c)</span></li>

</ul>

<p><a href="https://git.reviewboard.kde.org/r/119496/diff/" style="margin-left: \
3em;">View Diff</a></p>






  </td>
 </tr>
</table>








  </div>
 </body>
</html>


--===============6448841181282157174==--



_______________________________________________
calligra-devel mailing list
calligra-devel@kde.org
https://mail.kde.org/mailman/listinfo/calligra-devel


[prev in list] [next in list] [prev in thread] [next in thread] 

Configure | About | News | Add a list | Sponsored by KoreLogic