--===============0762822247917159932== Content-Type: multipart/alternative; boundary="===============6448841181282157174==" --===============6448841181282157174== MIME-Version: 1.0 Content-Type: text/plain; charset="utf-8" Content-Transfer-Encoding: 7bit > On July 27, 2014, 4:10 p.m., Elvis Stansvik wrote: > > cmake/modules/CalligraProductSetMacros.cmake, line 37 > > > > > > is this necessary? it just unsets ${_current_flag} right? (which has never been set at this point). > > Friedrich W. H. Kossebau wrote: > Not necessary right now, yes. But it is done to protect against any other code starting to use a var with that very name. Sadly there seems no way to limit the scope of vars to functions in CMake 2.x (AFAIK). Ah. Then it makes sense. > On July 27, 2014, 4:10 p.m., Elvis Stansvik wrote: > > cmake/modules/CalligraProductSetMacros.cmake, line 43 > > > > > > maybe use unset(..) instead? it's a little clearer i think. at least i had to consult the cmake docs to realize set(..) actually unsets when no value is passed in :) > > Friedrich W. H. Kossebau wrote: > unset() might be better to use, yes, good hint. Did not know it exists and got used to set() already :) > Will keep in mind and the next weeks prepare a cleanup patch for all those cases were unset() could be used instead of set() (unless someone beats me to it ;) ) Here you go: https://git.reviewboard.kde.org/r/119502/ :) - Elvis ----------------------------------------------------------- This is an automatically generated e-mail. To reply, visit: https://git.reviewboard.kde.org/r/119496/#review63263 ----------------------------------------------------------- On July 27, 2014, 3:55 p.m., Friedrich W. H. Kossebau wrote: > > ----------------------------------------------------------- > This is an automatically generated e-mail. To reply, visit: > https://git.reviewboard.kde.org/r/119496/ > ----------------------------------------------------------- > > (Updated July 27, 2014, 3:55 p.m.) > > > Review request for Calligra. > > > Repository: calligra > > > Description > ------- > > The current build system is slightly unprecise about which external dep is missing, there is only one generic string for each product if one or more of the external deps was/were missing. E.g. "libodfgen|libetonyek|librevenge devel not found" or "SharedMimeInfo|libeigen3|libexiv2|lcms|boost-system devel not found". > > This patch changes that by adding a new macro "calligra_drop_product_on_bad_condition" and adapting the current product-dropping-due-to-bad-external-deps code. As side effect it gives a nice listing of external deps for each product. > > Any better name for "calligra_drop_product_on_bad_condition"? > > (Also brings consistent handling of Xinput_FOUND as TRUE for Windows and OSX) > > > Diffs > ----- > > CMakeLists.txt f76746c > cmake/modules/CalligraProductSetMacros.cmake bdca16c > > Diff: https://git.reviewboard.kde.org/r/119496/diff/ > > > Testing > ------- > > > Thanks, > > Friedrich W. H. Kossebau > > --===============6448841181282157174== MIME-Version: 1.0 Content-Type: text/html; charset="utf-8" Content-Transfer-Encoding: 7bit
This is an automatically generated e-mail. To reply, visit: https://git.reviewboard.kde.org/r/119496/

On July 27th, 2014, 4:10 p.m. UTC, Elvis Stansvik wrote:

cmake/modules/CalligraProductSetMacros.cmake (Diff revision 1)
37
  set(_current_flag)

is this necessary? it just unsets ${_current_flag} right? (which has never been set at this point).

On July 27th, 2014, 4:25 p.m. UTC, Friedrich W. H. Kossebau wrote:

Not necessary right now, yes. But it is done to protect against any other code starting to use a var with that very name. Sadly there seems no way to limit the scope of vars to functions in CMake 2.x (AFAIK).

Ah. Then it makes sense.


On July 27th, 2014, 4:10 p.m. UTC, Elvis Stansvik wrote:

cmake/modules/CalligraProductSetMacros.cmake (Diff revision 1)
43
      set(_current_flag)

maybe use unset(..) instead? it's a little clearer i think. at least i had to consult the cmake docs to realize set(..) actually unsets when no value is passed in :)

On July 27th, 2014, 4:25 p.m. UTC, Friedrich W. H. Kossebau wrote:

unset() might be better to use, yes, good hint. Did not know it exists and got used to set() already :)
Will keep in mind and the next weeks prepare a cleanup patch for all those cases were unset() could be used instead of set() (unless someone beats me to it ;) )

Here you go: https://git.reviewboard.kde.org/r/119502/ :)


- Elvis


On July 27th, 2014, 3:55 p.m. UTC, Friedrich W. H. Kossebau wrote:

Review request for Calligra.
By Friedrich W. H. Kossebau.

Updated July 27, 2014, 3:55 p.m.

Repository: calligra

Description

The current build system is slightly unprecise about which external dep is missing, there is only one generic string for each product if one or more of the external deps was/were missing. E.g. "libodfgen|libetonyek|librevenge devel not found" or "SharedMimeInfo|libeigen3|libexiv2|lcms|boost-system devel not found".

This patch changes that by adding a new macro "calligra_drop_product_on_bad_condition" and adapting the current product-dropping-due-to-bad-external-deps code. As side effect it gives a nice listing of external deps for each product.

Any better name for "calligra_drop_product_on_bad_condition"?

(Also brings consistent handling of Xinput_FOUND as TRUE for Windows and OSX)

Diffs

  • CMakeLists.txt (f76746c)
  • cmake/modules/CalligraProductSetMacros.cmake (bdca16c)

View Diff

--===============6448841181282157174==-- --===============0762822247917159932== Content-Type: text/plain; charset="us-ascii" MIME-Version: 1.0 Content-Transfer-Encoding: 7bit Content-Disposition: inline _______________________________________________ calligra-devel mailing list calligra-devel@kde.org https://mail.kde.org/mailman/listinfo/calligra-devel --===============0762822247917159932==--