[prev in list] [next in list] [prev in thread] [next in thread] 

List:       kde-i18n-doc
Subject:    Re: Puzzle in libplasma?
From:       Chusslove Illich <caslav.ilic () gmx ! net>
Date:       2008-12-01 17:24:18
Message-ID: 200812011824.20683.caslav.ilic () gmx ! net
[Download RAW message or body]


> [: Karl Ove Hufthammer :]
> However, it doesn't, so I obviously have done something wrong. Could you
> explain how it should be written?

It all looks fine, except for:

  function bunden-element (str) {
      return getprop(str,"pron");
  }
  Ts.setcall("bunden-element", bunden-element);

because JavaScript function name cannot have minus in it, only [a-zA-Z_],
and getprop should be Ts.getProp. It worked for me (got "Fjern denne") when
I changed it to:

  function bunden_element (str) {
      return Ts.getProp(str,"pron");
  }
  Ts.setcall("bunden-element", bunden_element);

> This was just meant as an example to see if I could get it to work. The
> real translation should be formatted as ‘Fjern denne binærklokka'.
> Suggestion on how to best do this are also welcome. :) )

You pretty much have everything in there, just needs another scripting call
set up to get the noun form. For the lack of better names:

  function bunden_element_2 (str) {
      return Ts.getProp(str,"bunden");
  }
  Ts.setcall("bunden-element-2", bunden_element_2);

and then:

  msgid "Remove this %1"
  msgstr ""
  "Fjern  %1 "
  "|/|"
  "Fjern $[bunden-element %1] $[bunden-element-2 %1]"

gave me "Fjern denne binærklokka".

-- 
Chusslove Illich (Часлав Илић)
Serbian KDE translation team

[Attachment #3 (application/pgp-signature)]

[prev in list] [next in list] [prev in thread] [next in thread] 

Configure | About | News | Add a list | Sponsored by KoreLogic