[prev in list] [next in list] [prev in thread] [next in thread] 

List:       zebra
Subject:    [zebra 11012] Re: Translate commands form Cisco to Zebra
From:       John Narron <zeek () cdsinet ! net>
Date:       2001-10-30 21:58:44
[Download RAW message or body]

Try using something like this:

   access-list 1 permit 0.0.0.0/1
   access-list 2 permit 0.0.0.0/1

Cisco uses bitmasks (the 127.255.255.255 for instance) on access-lists,
which I personally think are a pain in the ass, and very confusing.
They really just an inverse of a netmask.. so..

   127.255.255.255 converts to 128.0.0.0 -> CIDR/1

(Blame any lack of accuracy on this due to the 4th martini I'm
 consuming *hick*)

However, I don't know if Zebra supports a CIDR mask of anything
smaller than /8 of which you'll need to do something like:

   access-list 1 permit 0.0.0.0/8
   access-list 1 permit 1.0.0.0/8
   access-list 1 permit 2.0.0.0/8
    ...
   access-list 1 permit 126.0.0.0/8

   access-list 2 deny   0.0.0.0/8
   access-list 2 deny   1.0.0.0/8
   access-list 2 deny   2.0.0.0/8
    ...
   access-list 2 deny   126.0.0.0/8
   access-list 2 permit any

(Don't need to do 127.0.0.0/8 - localhost after all, and
 you can probably skip 0.0.0.0/8 and 10.0.0.0/8)

Hope it helps,

	- John


On Tue, 30 Oct 2001, Van Howell wrote:

> Date: Tue, 30 Oct 2001 14:04:21 -0600
> From: Van Howell <vhowell@csgcomm.com>
> To: zebra@zebra.org
> Subject: [zebra 11010] Translate commands form Cisco to Zebra
>
> I have run across a Cisco Configuration that contains a line that Zebra will
> not accept. Could anyone translate it for me. The line is
>
> access-list 1 permit 0.0.0.0 127.255.255.255
> access-list 2 deny 0.0.0.0 127.255.255.255
>
> What this is suppose to do, along with some route-map statements, is to make
> any network lower thatn 128.0.0.0 go out one interface and the rest exit via
> the other interface.
>
> The remainder of the script it below
>
> neighbor 160.20.20.2 remote-as 10
> neighbor 160.20.20.2 route-map UPDATES-1 in
> neighbor 150.10.10.2 remote-as 12
> neighbor 150.10.10.2 route-map UPDATES-2 in
>
> route-map UPDATES-1 permit 10
> match ip address 1
> set weight 100
>
> route-map UPDATES-1 permit 20
> match ip address 2
>
> route-map UPDATES-2 permit 10
> match ip address 1
>
> route-map UPDATES-2 permit 20
> match ip address 2
> set weight 100
>
> access-list 1 permit 0.0.0.0 127.255.255.255
> access-list 2 deny 0.0.0.0 127.255.255.255
> access-list 2 permit any
>
>
>
>

[prev in list] [next in list] [prev in thread] [next in thread] 

Configure | About | News | Add a list | Sponsored by KoreLogic