[prev in list] [next in list] [prev in thread] [next in thread] 

List:       webkit-reviews
Subject:    [webkit-reviews] review denied: [Bug 38397] Add "preSubmitForm"
From:       bugzilla-daemon () webkit ! org
Date:       2010-04-30 20:01:43
Message-ID: 20100430200143.0A5553F8BE35 () gamma ! macosforge ! org
[Download RAW message or body]

Darin Fisher (:fishd, Google) <fishd@chromium.org> has denied Jens Alfke
<snej@chromium.org>'s request for review:
Bug 38397: Add "preSubmitForm" hook to FrameLoader
https://bugs.webkit.org/show_bug.cgi?id=38397

Attachment 54819: patch
https://bugs.webkit.org/attachment.cgi?id=54819&action=review

------- Additional Comments from Darin Fisher (:fishd, Google)
<fishd@chromium.org>
WebCore/html/HTMLFormElement.cpp:294
 +	frame->loader()->dispatchPreSubmitForm(this);
I would just do frame->loader()->client()->dispatch* here instead
of adding the intermediate FrameLoader method.

WebCore/loader/FrameLoaderClient.h:149
 +	    virtual void dispatchPreSubmitForm(HTMLFormElement*) { };
How about naming this dispatchWillSendSubmitEvent?  I think that name is more
accurate.

WebKit/chromium/public/WebFrameClient.h:143
 +	virtual void preSubmitForm(WebFrame*, const WebFormElement&) { }
willSendSubmitEvent
_______________________________________________
webkit-reviews mailing list
webkit-reviews@lists.webkit.org
http://lists.webkit.org/mailman/listinfo.cgi/webkit-reviews
[prev in list] [next in list] [prev in thread] [next in thread] 

Configure | About | News | Add a list | Sponsored by KoreLogic