[prev in list] [next in list] [prev in thread] [next in thread] 

List:       tapestry-dev
Subject:    [jira] Created: (TAPESTRY-2315) InjectContainerWorker should use
From:       "Wolfram Koska (JIRA)" <dev () tapestry ! apache ! org>
Date:       2008-03-30 0:07:24
Message-ID: 1854384011.1206835644488.JavaMail.jira () brutus
[Download RAW message or body]

InjectContainerWorker should use this or other local variable name than "container"
-----------------------------------------------------------------------------------

                 Key: TAPESTRY-2315
                 URL: https://issues.apache.org/jira/browse/TAPESTRY-2315
             Project: Tapestry
          Issue Type: Improvement
          Components: tapestry-core
    Affects Versions: 5.0.11
         Environment: any
            Reporter: Wolfram Koska
            Priority: Minor


What I did:

@InjectContainer
private Field container;

Resulted in: container == null

The InjectContainerWorker uses "container" as the name of a temporary local variable, \
and the assignment is done to the field name:

  builder.addln("%s = (%s) container;", fieldName, fieldType);

This resulted in:

  container = (org.apache.tapestry.Field) container;

Thus my instance variable was never assigned to. Should probably be

  builder.addln("this.%s = (%s) container;", fieldName, fieldType);

or use any other name for the temporary variable - might not be so uncommon for \
people to name the container "container", and can be very confusing.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@tapestry.apache.org
For additional commands, e-mail: dev-help@tapestry.apache.org


[prev in list] [next in list] [prev in thread] [next in thread] 

Configure | About | News | Add a list | Sponsored by KoreLogic