[prev in list] [next in list] [prev in thread] [next in thread] 

List:       sylpheed
Subject:    [sylpheed:24402] PATCH: Neglect empty Reply-To
From:       Alfons Hoogervorst <alfons () proteus ! demon ! nl>
Date:       2005-03-19 19:00:12
Message-ID: 20050319200012.1847b2e6.alfons () proteus ! demon ! nl
[Download RAW message or body]

Lo Hiro,

Even if an empty reply-to is set, just neglecting it would be better. 

Some projects (Exim) / documents
(http://mailformat.dan.info/headers/from.html) suggest using the From:
header, which is what Sylpheed normally does I guess.

Oh, and in the everlasting quest of writing better code, let me assure
you: your strncpy2() is more readable than mine. ;-)

Bye.

-- 
Ecuación algebraico sin solución posible,
a menos de poseer profundos conocimientos
en matemática - Revueltas (Ocho Por Radio)


["compose.c.patch" (text/plain)]

Index: trunk/src/compose.c
===================================================================
--- trunk/src/compose.c	(revision 184)
+++ trunk/src/compose.c	(working copy)
@@ -1262,6 +1262,12 @@
 			conv_unmime_header(hentry[H_REPLY_TO].body, NULL);
 		g_free(hentry[H_REPLY_TO].body);
 		hentry[H_REPLY_TO].body = NULL;
+                /* if empty replyto, let sylpheed figure it out, i.e.
+                 * neglect the reply-to header. */
+                if (*(compose->replyto) == 0) {
+                        g_free(compose->replyto);
+                        compose->replyto = NULL;
+                }                        
 	}
 	if (hentry[H_CC].body != NULL) {
 		compose->cc = conv_unmime_header(hentry[H_CC].body, NULL);



[prev in list] [next in list] [prev in thread] [next in thread] 

Configure | About | News | Add a list | Sponsored by KoreLogic