[prev in list] [next in list] [prev in thread] [next in thread] 

List:       subversion-users
Subject:    Re: svnwcsub.py - various pylint errors
From:       Daniel Shahaf <d.s () daniel ! shahaf ! name>
Date:       2021-05-13 14:23:56
Message-ID: 20210513142356.GE10841 () tarpaulin ! shahaf ! local2
[Download RAW message or body]

sebb wrote on Wed, May 12, 2021 at 12:25:26 +0100:
> pylint reports quite a few warnings and errors:
> 
> svnwcsub.py:55:0: W0311: Bad indentation. Found 2 spaces, expected 4
> (bad-indentation)

Don't hard-wrap program output in your emails.

> svnwcsub.py:57:0: W0311: Bad indentation. Found 2 spaces, expected 4 (bad-indentation)
> svnwcsub.py:61:0: W0311: Bad indentation. Found 2 spaces, expected 4 (bad-indentation)
> svnwcsub.py:63:0: W0311: Bad indentation. Found 2 spaces, expected 4 (bad-indentation)
> svnwcsub.py:67:0: W0311: Bad indentation. Found 2 spaces, expected 4 (bad-indentation)
> svnwcsub.py:69:0: W0311: Bad indentation. Found 2 spaces, expected 4 (bad-indentation)

I know it's PEP8, but the churn isn't worthwhile, IMO, especially as the
entire core tests directory uses non-PEP8 indentation.  Thus, I'm voting
WONTFIX.

editorconfig(5) is already set correctly for these.

> svnwcsub.py:87:4: W0612: Unused variable 'output' (unused-variable)

I suppose you could change it to  «_, errput = … », but it's rather
a borderline case insofar as readability v. churn is concerned, IMO.

> svnwcsub.py:115:12: W0612: Unused variable 'x' (unused-variable)

How'd you rewrite it?

> svnwcsub.py:439:38: W0613: Unused argument 'event_arg' (unused-argument)

Looks like a false positive.  Did you triage these warnings before you
posted them to the list?

> svnwcsub.py:46:0: W0611: Unused import errno (unused-import)
> svnwcsub.py:58:0: W0611: Unused import time (unused-import)
> svnwcsub.py:65:0: W0611: Unused import functools (unused-import)
> svnwcsub.py:67:2: W0611: Unused import urlparse (unused-import)
> svnwcsub.py:69:2: W0611: Unused urllib.parse imported as urlparse (unused-import)

Patch please.

> svnwcsub.py:378:18: E0602: Undefined variable 'fname' (undefined-variable)
> (should be self.fname)

Did you reproduce the bug and confirm the proposed change fixes it?  If
so, post a complete patch, please.
[prev in list] [next in list] [prev in thread] [next in thread] 

Configure | About | News | Add a list | Sponsored by KoreLogic