[prev in list] [next in list] [prev in thread] [next in thread] 

List:       quagga-users
Subject:    [quagga-users 11976] OSPF - influencing the inbound route of traffic
From:       Alex Kramarov <alex-quagga () incredimail ! com>
Date:       2010-12-05 19:00:15
Message-ID: 4CFBE13F.5010008 () incredimail ! com
[Download RAW message or body]

I have a problem that i have been trying to solve for a few days now. I 
have a hub and spoke configuration of a central data center and branch 
offices, each branch connected to central by an openvpn tunnel. Up until 
now this was configured with static routes and worked well. A month ago 
i got an internet connection from a second ISP to the central location, 
so the first idea was to have 2 vpn connections from each branch, one 
through primary ISP and one through secondary, and run dynamic routing 
over these. I am trying to resolve 1) primary isp failure, need to 
failover to secondary isp 2) primary isp high packet loss, need to 
failover to secondary isp.

using rip i am able to achieve this :

HUB :

router rip
  timers basic 5 15 30
  redistribute connected
  network tap0
  network tap1
  passive-interface default
  no passive-interface tap0
  no passive-interface tap1
!

SPOKE :

router rip
  timers basic 5 15 30
  redistribute connected
  offset-list default-list in 1 tap0
  offset-list default-list out 1 tap0
  offset-list default-list in 5 tap1
  offset-list default-list out 5 tap1
  network tap0
  network tap1
  passive-interface default
  no passive-interface tap0
  no passive-interface tap1
!
access-list default-list permit any

in this configuration i am able to control the flow of traffic in both 
direction (from the spoke and to the spoke), normally traffic flows 
through tap0. If i want it to flow through tap1, i can issue the " 
offset-list default-list in 10 tap0 ; offset-list default-list out 10 
tap0 " on the spoke and all the incoming the outgoing traffic will 
switch to tap1. Now, i have been trying to get this one to work with ospf :

interface tap0
  ip ospf cost 12
!
interface tap1
  ip ospf cost 13
!
router ospf
  ospf router-id 10.10.0.10
  log-adjacency-changes detail
  redistribute connected
  passive-interface default
  no passive-interface tap0
  no passive-interface tap1
  network 172.16.10.0/25 area 0.0.0.0
  network 172.16.10.128/25 area 0.0.0.0
!

the branch has the following :

interface tap0
  ip ospf cost 12
!
interface tap1
  ip ospf cost 13
!
router ospf
  ospf router-id 10.0.50.3
  redistribute connected
  passive-interface default
  no passive-interface tap0
  no passive-interface tap1
  network 172.16.10.0/25 area 0.0.0.0
  network 172.16.10.128/25 area 0.0.0.0
!

Normally all traffic flows through tap0. If tap0 goes down for any case, 
all traffic will flow through tap1. I also can send traffic through tap1 
by changing the interface costs. The problem is handling the scenario 
where packet loss is detected - i want to be able to run the packet loss 
detection logic from the branch only, and to advertise the local 
prefixes to be preferred over tap1 (for bgp i would set a route map with 
"set as-path prepend" at tap0 to have the hub send data to the branch 
over tap1 instead of the default tap0). I don't want to take down tap0 
at the branch to force the traffic to flow through tap1. Is there a way 
to advertise prefixes from the same quagga router with different 
metric/distance/whatever over different interfaces (or to 2 different 
neighbors, since the branch sees the hub as 2 different neighbors : 
172.16.10.1 and 172.16.10.129) so i could get incoming traffic on tap1 
instead of tap0 without changing the HUB configuration ?
_______________________________________________
Quagga-users mailing list
Quagga-users@lists.quagga.net
http://lists.quagga.net/mailman/listinfo/quagga-users
[prev in list] [next in list] [prev in thread] [next in thread] 

Configure | About | News | Add a list | Sponsored by KoreLogic