[prev in list] [next in list] [prev in thread] [next in thread] 

List:       phpslash
Subject:    [phpslash] cvs commit
From:       daniel <phpslash () lists ! netuse ! de>
Date:       2000-06-30 20:49:10
[Download RAW message or body]

From: daniel
Date: Fri Jun 30 22:49:10 2000
Modified files:
      phpslash-ft/doc/COMMIT
      phpslash-ft/doc/newdbscheme
      phpslash-ft/CHANGES

Log message:
*	doc/newdbcheme: removed reference to psl_story.section (which doesn't exist
anymore), updated psl_topic.onlinkbar explanation, added a note to
psl_topic.image (no path)

*   doc/COMMIT: added our new standard for variables, functions and classes;
fixed typos; fixed indentation example (was using 2 spaces)
	  


Index: phpslash-ft/doc/COMMIT
diff -u phpslash-ft/doc/COMMIT:1.3 phpslash-ft/doc/COMMIT:1.4
--- phpslash-ft/doc/COMMIT:1.3	Tue Jun 13 01:21:52 2000
+++ phpslash-ft/doc/COMMIT	Fri Jun 30 22:48:39 2000
@@ -1,4 +1,4 @@
-$Id: COMMIT,v 1.3 2000/06/12 23:21:52 ajay Exp $
+$Id: COMMIT,v 1.4 2000/06/30 20:48:39 daniel Exp $
 
 Some rules for phpSlash CVS committers:
 
@@ -16,7 +16,7 @@
 Comments: 
   - Use C-Style /* */ and // comments only. # Should be phased out
   - Use // for in code comments, but /* */ for headers and multi-line
-    comments (ie: trning off Debug features)
+    comments (ie: turning off Debug features)
   - Always include your initals or cvs username (if you have one) and
     preferably your email address if it is not in the CREDITS file
   - Please leave intelligent notes in comments.  Refrain from:
@@ -29,13 +29,14 @@
     (esp. for Regular Expressions)
 
 Functions / Objects:  
-  - Should be well commented as to their arguments, what they do
+  - Should be well commented as to their arguments, return value, what they do
     and how they work.  This should take place on the lines preceding the
-    function decleration.
+    function declaration.
   - Should be as minimalistic as possible. If it can be bnroken into two
     functions, please do so.  
   - Wrapper functions to provide multiple methods of output are highly
     recommended.
+  - Functions should be named likeThis() and classes LikeThis.
 
 Variable Naming:
   - Hungarian Notation is prefered for things that are gloablly
@@ -54,19 +55,19 @@
   - No tabs anywhere, spaces only.
   For Example:
   someFunction() {
-    if ($someVar) {
-      doOtherFunction();
-    } else {
-      error("You *are* stupid!  Don't do that");
-    }
+     if ($someVar) {
+        doOtherFunction();
+     } else {
+        error("You *are* stupid!  Don't do that");
+     }
   }
 
 Module / Class / Include file Format:
   - Should start with a line(s) that tells a reader what it is, what
-    package it comes from, what it does, CVS $Id: COMMIT,v 1.3 2000/06/12 23:21:52 ajay Exp $ line
+    package it comes from, what it does, CVS $Id: COMMIT,v 1.4 2000/06/30 20:48:39 daniel Exp $ line
   - Templates are an execption to that above rule.  They should have an
     HTML comment in them that points their ownership to a class
-  - Setup any neeed variable first, then include() files, then declare
+  - Setup any needed variable first, then include() files, then declare
     functions, then page processing, then page output.
 
 Docs:
@@ -84,7 +85,7 @@
                    [...snip...]
               FROM psl_story story,
                    [...snip...]
-             WHERE story.story_id='$story_id'
+             WHERE story.story_id = '$story_id'
                AND authors.aid = story.user_id
                    [...snip...]
 
Index: phpslash-ft/doc/newdbscheme
diff -u phpslash-ft/doc/newdbscheme:1.1 phpslash-ft/doc/newdbscheme:1.2
--- phpslash-ft/doc/newdbscheme:1.1	Thu Jun  1 23:06:38 2000
+++ phpslash-ft/doc/newdbscheme	Fri Jun 30 22:48:39 2000
@@ -31,7 +31,6 @@
   intro_text   - text that's on the index.
   body_text    - everything that's comes after the intro.
   hits         - number of times people have read the body.
-  section      - section id (apache, bsd, askslashdot, etc..)
 
 psl_submission  *
   [this will be a "mirror" copy of the psl_story structure.  That way
@@ -61,12 +60,13 @@
 
 psl_topic 
   topic_id  - id of topic
-* topic_name- name of the topic
-  image     - filename of the image
+  topic_name- name of the topic
+  image     - filename of the image (no path)
   alt_text  - the stuff that goes in the ALT="" attribute of the IMG tag
   width     - width of the image
   height    - height of the image
-  onlinkbar - true/false.  weather or not this icon shows up on the main page
+* onlinkbar - integer, order of the topics on the topicbar (1 = leftmost)
+              if 0, this topic won't be displayed in the topicbar
 
   psl_topic_lut
     topic_lut_id - id of the lut entry (is this needed?)
Index: phpslash-ft/CHANGES
diff -u phpslash-ft/CHANGES:1.30 phpslash-ft/CHANGES:1.31
--- phpslash-ft/CHANGES:1.30	Wed Jun 28 23:47:56 2000
+++ phpslash-ft/CHANGES	Fri Jun 30 22:48:39 2000
@@ -1,5 +1,12 @@
-$Id: CHANGES,v 1.30 2000/06/28 21:47:56 daniel Exp $
+$Id: CHANGES,v 1.31 2000/06/30 20:48:39 daniel Exp $
 
+2000-Jun-30 Daniel Serodio <daniel@ibnetwork.com.br>
+o doc/newdbcheme: removed reference to psl_story.section (which doesn't exist
+  anymore), updated psl_topic.onlinkbar explanation, added a note to
+  psl_topic.image (no path)
+o doc/COMMIT: added our new standard for variables, functions and classes;
+  fixed typos; fixed indentation example (was using 2 spaces)
+  
 2000-Jun-28 Daniel Serodio <daniel@ibnetwork.com.br>
 o Comment.class: indentation, whitespace, renamed $scid to $comment_id,
   added CVS $Id tag (how can I properly quote that?), removed reference to



---------------------------------------------------------------------
To unsubscribe, e-mail: phpslash-unsubscribe@lists.netuse.de
For additional commands, e-mail: phpslash-help@lists.netuse.de

[prev in list] [next in list] [prev in thread] [next in thread] 

Configure | About | News | Add a list | Sponsored by KoreLogic