[prev in list] [next in list] [prev in thread] [next in thread] 

List:       openjdk-swing-dev
Subject:    <Swing Dev> review request for 6899434: Add affine transform support to JLayer
From:       pbhome () ziggo ! nl (Piet Blok)
Date:       2010-01-28 17:21:16
Message-ID: 7DA864E83CAE4D4D9EBAC77237DEF6B9 () DB35TT0J
[Download RAW message or body]

Hello all,

review request for 6899434: Add affine transform support to JLayer

The webrev: http://www.pbjar.org/OpenJDK/6899434/webrev/

The patch covers all the requested functionality. It is concentrated in 
JLayer class, keeping in mind to affect the library as little as possible.

1) A setter and getter for the transform in JLayer

2) The paint method in JLayer has been adapted to use the transform

3) RepaintManager has been adapted to propagate repaint requests from the 
view or any of its children to the top level JLayer and have the dirty 
region transformed.

4) java.awt.Container and java.awt.LightweightDispatcher (both in the same 
source) have been adapted to redispatch MouseEvents to the intended target 
component. The lookup for the component that provides a custon cursor has 
also been adapted.

5) To enable Container to do necessary reculculations, a protected method 
has been introduced that will be overridden by JLayer:
   protected Point getConvertedPoint(Point point).
(If someone can suggest a better name for this method I'm glad to hear)

6) A package private method in SwingUtilities has been added that helps 
JPopupMenu and ToolTipManager to find the correct popup location. JPopupMenu 
and ToolTipManager have been changed to use this new method in their 
calculations.

7) Two jtreg tests have been added.

Looking forward for comments.

Thanks,
Piet




[prev in list] [next in list] [prev in thread] [next in thread] 

Configure | About | News | Add a list | Sponsored by KoreLogic