[prev in list] [next in list] [prev in thread] [next in thread] 

List:       openjdk-openjfx-dev
Subject:    Re: [Rev 01] RFR: 8242523: Update the animation and clip envelope classes
From:       Kevin Rushforth <kcr () openjdk ! java ! net>
Date:       2020-05-28 17:05:16
Message-ID: GFVrCoYcL127j7WxAK0P9f-kfuvF9g7fP7Bc5iHN4Ew=.1486b633-bab7-46af-8982-539f6b1ebffa () github ! com
[Download RAW message or body]

On Thu, 28 May 2020 16:44:33 GMT, Nir Lisker <nlisker@openjdk.org> wrote:

> > Mostly refactoring in preparation of the upcoming fixes. The changes might look \
> > like a lot, but it's mostly rearranging of methods. Summery of changes:
> > ### Animation
> > * Added `isNearZero` and `areNearEqual` methods that deal with `EPSILON` checks.
> > * Added `isStopped`, `isRunning` and `isPaused` convenience methods.
> > * Added `runHandler` method to deal with running the handler.
> > * Moved methods to be grouped closer to where they are used rather than by \
> >                 visibility.
> > * Removed the static import for `TickCalculation`.
> > * Various small subjective readability changes.
> > * Behavioral changes: switching `autoReverse` and `onFinished` properties from \
> > "Simple" to "Base" properties; and lazily initializing the `cuePoints` map.
> > 
> > ### Clip Envelopes
> > * Added `MultiLoopClipEnvelope` as an intermediate parent for infinite and finite \
> >                 clip envelopes.
> > * Rearranged methods order to be consistent.
> > * Replaced the `checkBounds` method with a new overload of `Utils.clamp`.
> > * Renamed `pos` to `cyclePos`.
> > * Extracted common methods: `changedDirection` and `ticksRateChange`
> > * Added internal documentation.
> > 
> > Also corrected a typo in `TicksCalculation` and added an explanation for an \
> > animation test.
> 
> Nir Lisker has updated the pull request with a new target base due to a merge or a \
> rebase. The pull request now contains 10 commits:
> - Merge branch 'master' into 8242523_Update_the_Animation_and_ClipEnvelope_classes
> - Synch whitespace fix
> - Addressed review comments
> - Removing cycleNumber for now
> - Fix typo in TicksCalculation & add an explanation for an animation test
> - Initial push of 8242523
> - Comment out erroneous test
> - Fix IndefiniteCycleDuration test
> - Fixed single loop test
> - Initial commit

Marked as reviewed by kcr (Lead).

-------------

PR: https://git.openjdk.java.net/jfx/pull/196


[prev in list] [next in list] [prev in thread] [next in thread] 

Configure | About | News | Add a list | Sponsored by KoreLogic