[prev in list] [next in list] [prev in thread] [next in thread] 

List:       openjdk-hotspot-runtime-dev
Subject:    Re: RFR: 8252842: Extend jmap to support parallel heap dump [v21]
From:       Chris Plummer <cjplummer () openjdk ! java ! net>
Date:       2021-04-30 19:34:07
Message-ID: U2RADGPhUP3vk9C4SZ88oR-jWXYtu2OOwBRT3e0LHoI=.d40f5bae-98e6-4018-b555-4b0e2f0a3317 () github ! com
[Download RAW message or body]

On Mon, 26 Apr 2021 12:45:56 GMT, Lin Zang <lzang@openjdk.org> wrote:

> > 8252842: Extend jmap to support parallel heap dump
> 
> Lin Zang has updated the pull request with a new target base due to a merge or a \
> rebase. The pull request now contains 27 commits: 
> - Merge branch 'master' into par-dump
> - refine with several fix
> - Merge branch 'master' into par-dump
> - Merge branch 'master' into par-dump
> - Typo fix
> - remove parallel option and dumpheapext command
> - Revert "hide the dumpheapext error message"
> 
> This reverts commit 1af0e1e2bfab4f5d079c03ff0cb25067acacdac4.
> - resize large object threshold
> - Merge branch 'master' into par-dump
> - Merge branch 'master' into par-dump
> - ... and 17 more: https://git.openjdk.java.net/jdk/compare/c3ac6900...6d14790a

src/hotspot/share/services/heapDumperCompression.cpp line 240:

> 238: }
> 239: 
> 240: void CompressionBackend::flush_buffer_without_lock(MonitorLocker* ml) {

I'm trying to think of a better name since "without_lock" makes it sound like there \
is no locking, but there is. The difference is the lock is passed in. How about just \
calling it `flush_buffer(MonitorLocker* ml)` and rely on C++ method overloading to \
disambiguate it from `flush_buffer()`.

-------------

PR: https://git.openjdk.java.net/jdk/pull/2261


[prev in list] [next in list] [prev in thread] [next in thread] 

Configure | About | News | Add a list | Sponsored by KoreLogic