[prev in list] [next in list] [prev in thread] [next in thread] 

List:       mozilla-patches
Subject:    warning fix : ns/lib/layout/editor.h
From:       Rick Osborne <rick () spacey ! net>
Date:       1998-04-14 0:59:30
[Download RAW message or body]

(In the continuing quest to eliminate even compiler warnings ... )

warning : 'IsPositioned': member function definition looks like a ctor, but
name does not match enclosing class

This function is only called once in editor.cpp and is in an if() with a
subclass member that returns and int, so I figured an int return type would
be the most appropriate.  I guess VC5 doesn't like member functions with no
return types if they aren't ctors?

Bugzilla #196.

--- editor.old.h        Wed Apr 08 17:52:21 1998
+++ editor.h    Mon Apr 13 20:49:51 1998
@@ -1990,3 +1990,3 @@ public:
     CEditElement* Element() { return m_pElement; }
-    IsPositioned(){ return m_pElement != 0; }
+    int IsPositioned(){ return m_pElement != 0; }
 };

<!-- Rick Osborne -- http://www.rixsoft.com/resume.pdf -->
In a Bucharest hotel lobby: The lift is being fixed for the next day.
During that time we regret that you will be unbearable.

[prev in list] [next in list] [prev in thread] [next in thread] 

Configure | About | News | Add a list | Sponsored by KoreLogic