[prev in list] [next in list] [prev in thread] [next in thread] 

List:       linux-mm
Subject:    Re: [PATCH -v4 RESEND 8/9] mm, THP, swap: Support to split THP in swap cache
From:       "Huang\, Ying" <ying.huang () intel ! com>
Date:       2016-10-31 1:26:59
Message-ID: 871syx71gc.fsf () yhuang-dev ! intel ! com
[Download RAW message or body]

Hillf Danton <hillf.zj@alibaba-inc.com> writes:

> On Friday, October 28, 2016 1:56 PM Huang, Ying wrote: 
>> @@ -2016,10 +2021,12 @@ int page_trans_huge_mapcount(struct page *page, int *total_mapcount)
>>  /* Racy check whether the huge page can be split */
>>  bool can_split_huge_page(struct page *page)
>>  {
>> -	int extra_pins = 0;
>> +	int extra_pins;
>> 
>>  	/* Additional pins from radix tree */
>> -	if (!PageAnon(page))
>> +	if (PageAnon(page))
>> +		extra_pins = PageSwapCache(page) ? HPAGE_PMD_NR : 0;
>> +	else
>>  		extra_pins = HPAGE_PMD_NR;
>
> extra_pins is computed in this newly added helper.
>
>>  	return total_mapcount(page) == page_count(page) - extra_pins - 1;
>>  }
>> @@ -2072,7 +2079,7 @@ int split_huge_page_to_list(struct page *page, struct list_head *list)
>>  			ret = -EBUSY;
>>  			goto out;
>>  		}
>> -		extra_pins = 0;
>> +		extra_pins = PageSwapCache(head) ? HPAGE_PMD_NR : 0;
>
> It is also computed at the call site, so can we fold them into one?

Sounds reasonable.  I will add another argument to can_split_huge_page()
to return extra_pins, so we can avoid duplicated code and calculation.

Best Regards,
Huang, Ying

>>  		mapping = NULL;
>>  		anon_vma_lock_write(anon_vma);
>>  	} else {
>> --
>> 2.9.3

--
To unsubscribe, send a message with 'unsubscribe linux-mm' in
the body to majordomo@kvack.org.  For more info on Linux MM,
see: http://www.linux-mm.org/ .
Don't email: <a href=mailto:"dont@kvack.org"> email@kvack.org </a>
[prev in list] [next in list] [prev in thread] [next in thread] 

Configure | About | News | Add a list | Sponsored by KoreLogic