[prev in list] [next in list] [prev in thread] [next in thread] 

List:       linux-kernel
Subject:    Re: [PATCH net-next 07/10] r8169:change function name of function "rtl_w1w0_eri"
From:       Francois Romieu <romieu () fr ! zoreil ! com>
Date:       2014-09-30 22:37:07
Message-ID: 20140930223707.GB27610 () electric-eye ! fr ! zoreil ! com
[Download RAW message or body]

Chun-Hao Lin <hau@realtek.com> :
> Change the name of this function to "rtl_w0_w1_eri".
> It is more suitable for this function's behavior.

Afaiks it used to follow the same rule as the one I outlined in the
comment to #6/10 for rtl_w0_w1_phy.

Could you elaborate (or say so if it should be clear for me after
some sleep) ?

[...]
> diff --git a/drivers/net/ethernet/realtek/r8169.c b/drivers/net/ethernet/realtek/r8169.c
> index e68fe5e..e79def5 100644
> --- a/drivers/net/ethernet/realtek/r8169.c
> +++ b/drivers/net/ethernet/realtek/r8169.c
[...]
> @@ -1629,14 +1629,14 @@ static void __rtl8169_set_wol(struct rtl8169_private *tp, u32 wolopts)
>  	case RTL_GIGA_MAC_VER_48:
>  		tmp = ARRAY_SIZE(cfg) - 1;
>  		if (wolopts & WAKE_MAGIC)
> -			rtl_w1w0_eri(tp,
> +			rtl_w0w1_eri(tp,
>  				     0x0dc,
>  				     ERIAR_MASK_0100,
>  				     MagicPacket_v2,
>  				     0x0000,
>  				     ERIAR_EXGMAC);
>  		else
> -			rtl_w1w0_eri(tp,
> +			rtl_w0w1_eri(tp,
>  				     0x0dc,
>  				     ERIAR_MASK_0100,
>  				     0x0000,

Please turn these into:

			rtl_..._eri(tp, 0x0dc, ERIAR_MASK_0100, MagicPacket_v2,
 				    0x0000, ERIAR_EXGMAC);

-- 
Ueimor
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/
[prev in list] [next in list] [prev in thread] [next in thread] 

Configure | About | News | Add a list | Sponsored by KoreLogic