[prev in list] [next in list] [prev in thread] [next in thread] 

List:       linux-crypto-vger
Subject:    Re: [PATCH v2 4/8] s390: replace zfcp_qdio_sbale_count by sg_nents
From:       Steffen Maier <maier () linux ! vnet ! ibm ! com>
Date:       2015-09-30 13:59:16
Message-ID: 560BEAB4.10702 () linux ! vnet ! ibm ! com
[Download RAW message or body]

Thanks, looks good.

I've added it to my queue for sending zfcp patches upstream next time 
(might take a while).

On 09/18/2015 02:57 PM, LABBE Corentin wrote:
> The zfcp_qdio_sbale_count function do the same work than sg_nents().
> So replace it by sg_nents() for removing duplicate code.
>
> Signed-off-by: LABBE Corentin <clabbe.montjoie@gmail.com>
> ---
>   drivers/s390/scsi/zfcp_fsf.c  |  3 +--
>   drivers/s390/scsi/zfcp_qdio.h | 15 ---------------
>   2 files changed, 1 insertion(+), 17 deletions(-)
>
> diff --git a/drivers/s390/scsi/zfcp_fsf.c b/drivers/s390/scsi/zfcp_fsf.c
> index 522a633..edc137a 100644
> --- a/drivers/s390/scsi/zfcp_fsf.c
> +++ b/drivers/s390/scsi/zfcp_fsf.c
> @@ -985,8 +985,7 @@ static int zfcp_fsf_setup_ct_els_sbals(struct zfcp_fsf_req *req,
>   		if (zfcp_qdio_sbals_from_sg(qdio, &req->qdio_req, sg_resp))
>   			return -EIO;
>
> -		zfcp_qdio_set_data_div(qdio, &req->qdio_req,
> -					zfcp_qdio_sbale_count(sg_req));
> +		zfcp_qdio_set_data_div(qdio, &req->qdio_req, sg_nents(sg_req));
>   		zfcp_qdio_set_sbale_last(qdio, &req->qdio_req);
>   		zfcp_qdio_set_scount(qdio, &req->qdio_req);
>   		return 0;
> diff --git a/drivers/s390/scsi/zfcp_qdio.h b/drivers/s390/scsi/zfcp_qdio.h
> index 497cd37..85cdb82 100644
> --- a/drivers/s390/scsi/zfcp_qdio.h
> +++ b/drivers/s390/scsi/zfcp_qdio.h
> @@ -225,21 +225,6 @@ void zfcp_qdio_set_data_div(struct zfcp_qdio *qdio,
>   }
>
>   /**
> - * zfcp_qdio_sbale_count - count sbale used
> - * @sg: pointer to struct scatterlist
> - */
> -static inline
> -unsigned int zfcp_qdio_sbale_count(struct scatterlist *sg)
> -{
> -	unsigned int count = 0;
> -
> -	for (; sg; sg = sg_next(sg))
> -		count++;
> -
> -	return count;
> -}
> -
> -/**
>    * zfcp_qdio_real_bytes - count bytes used
>    * @sg: pointer to struct scatterlist
>    */
>

-- 
Mit freundlichen Grüßen / Kind regards
Steffen Maier

Linux on z Systems Development

IBM Deutschland Research & Development GmbH
Vorsitzende des Aufsichtsrats: Martina Koederitz
Geschaeftsfuehrung: Dirk Wittkopp
Sitz der Gesellschaft: Boeblingen
Registergericht: Amtsgericht Stuttgart, HRB 243294

--
To unsubscribe from this list: send the line "unsubscribe linux-crypto" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
[prev in list] [next in list] [prev in thread] [next in thread] 

Configure | About | News | Add a list | Sponsored by KoreLogic