[prev in list] [next in list] [prev in thread] [next in thread] 

List:       linux-backports
Subject:    [PATCH 4/6] header: add NETIF_F_SCTP_CRC
From:       Hauke Mehrtens <hauke () hauke-m ! de>
Date:       2015-12-21 0:05:59
Message-ID: 1450656361-21259-5-git-send-email-hauke () hauke-m ! de
[Download RAW message or body]

NETIF_F_SCTP_CSUM was renamed to NETIF_F_SCTP_CRC in commit 53692b1de
"sctp: Rename NETIF_F_SCTP_CSUM to NETIF_F_SCTP_CRC" make new code
still work with old kernel.

Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
---
 backport/backport-include/linux/netdev_features.h | 5 +++++
 1 file changed, 5 insertions(+)

diff --git a/backport/backport-include/linux/netdev_features.h \
b/backport/backport-include/linux/netdev_features.h index 350283d..3ca13e2 100644
--- a/backport/backport-include/linux/netdev_features.h
+++ b/backport/backport-include/linux/netdev_features.h
@@ -45,4 +45,9 @@ typedef u32 netdev_features_t;
 #define NETIF_F_RXFCS 0
 #endif
 
+/* this was renamed in commit 53692b1de :  sctp: Rename NETIF_F_SCTP_CSUM to \
NETIF_F_SCTP_CRC */ +#ifndef NETIF_F_SCTP_CRC
+#define NETIF_F_SCTP_CRC __NETIF_F(SCTP_CSUM)
+#endif
+
 #endif /* __BACKPORT_NETDEV_FEATURES_H */
-- 
2.6.4

--
To unsubscribe from this list: send the line "unsubscribe backports" in


[prev in list] [next in list] [prev in thread] [next in thread] 

Configure | About | News | Add a list | Sponsored by KoreLogic