[prev in list] [next in list] [prev in thread] [next in thread] 

List:       kwin
Subject:    Re: Review Request: Make Bouncing Cursor respect Small Icon size
From:       "Kai Uwe Broulik" <kde () privat ! broulik ! de>
Date:       2012-08-24 16:07:52
Message-ID: 20120824160752.29874.60287 () vidsolbach ! de
[Download RAW message or body]

[Attachment #2 (multipart/alternative)]


> On Aug. 24, 2012, 4:06 p.m., Thomas Lübking wrote:
> > kwin/effects/startupfeedback/startupfeedback.cpp, line 316
> > <http://git.reviewboard.kde.org/r/106166/diff/1/?file=80918#file80918line316>
> > 
> > m_boucingSizesRatio is only conditionally initialized (ie. "else \
> > m_boucingSizesRatio = 1.0;")

I actually only if'd it out because I feared it might be a heavy operation. Is it \
okay to always call that function?


- Kai Uwe


-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
http://git.reviewboard.kde.org/r/106166/#review17952
-----------------------------------------------------------


On Aug. 24, 2012, 3:32 p.m., Kai Uwe Broulik wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> http://git.reviewboard.kde.org/r/106166/
> -----------------------------------------------------------
> 
> (Updated Aug. 24, 2012, 3:32 p.m.)
> 
> 
> Review request for kwin.
> 
> 
> Description
> -------
> 
> This patch makes KWin's startup feedback effect aka bouncing cursor respect the \
> global small icon size. The icon was loaded correctly but scaled to a fixed size \
> previously. (The variable could be given a better name for sure)
> 
> 
> This addresses bug 305611.
> http://bugs.kde.org/show_bug.cgi?id=305611
> 
> 
> Diffs
> -----
> 
> kwin/effects/startupfeedback/startupfeedback.h 6758354 
> kwin/effects/startupfeedback/startupfeedback.cpp ff6a51e 
> 
> Diff: http://git.reviewboard.kde.org/r/106166/diff/
> 
> 
> Testing
> -------
> 
> Tested with 16, 22 and 48 icon size and works fine.
> 
> 
> Thanks,
> 
> Kai Uwe Broulik
> 
> 


[Attachment #5 (text/html)]

<html>
 <body>
  <div style="font-family: Verdana, Arial, Helvetica, Sans-Serif;">
   <table bgcolor="#f9f3c9" width="100%" cellpadding="8" style="border: 1px #c9c399 \
solid;">  <tr>
     <td>
      This is an automatically generated e-mail. To reply, visit:
      <a href="http://git.reviewboard.kde.org/r/106166/">http://git.reviewboard.kde.org/r/106166/</a>
  </td>
    </tr>
   </table>
   <br />








<blockquote style="margin-left: 1em; border-left: 2px solid #d0d0d0; padding-left: \
10px;">  <p style="margin-top: 0;">On August 24th, 2012, 4:06 p.m., <b>Thomas \
Lübking</b> wrote:</p>  <blockquote style="margin-left: 1em; border-left: 2px solid \
#d0d0d0; padding-left: 10px;">  



<table width="100%" border="0" bgcolor="white" style="border: 1px solid #C0C0C0; \
border-collapse: collapse; margin: 2px padding: 2px;">  <thead>
  <tr>
   <th colspan="4" bgcolor="#F0F0F0" style="border-bottom: 1px solid #C0C0C0; \
font-size: 9pt; padding: 4px 8px; text-align: left;">  <a \
href="http://git.reviewboard.kde.org/r/106166/diff/1/?file=80918#file80918line316" \
style="color: black; font-weight: bold; text-decoration: \
underline;">kwin/effects/startupfeedback/startupfeedback.cpp</a>  <span \
style="font-weight: normal;">

     (Diff revision 1)

    </span>
   </th>
  </tr>
 </thead>

 <tbody style="background-color: #e4d9cb; padding: 4px 8px; text-align: center;">
  <tr>

   <td colspan="4"><pre style="font-size: 8pt; line-height: 140%; margin: 0; ">void \
StartupFeedbackEffect::start(const QString&amp; icon)</pre></td>

  </tr>
 </tbody>




 
 



 <tbody>

  <tr>
    <th bgcolor="#b1ebb0" style="border-right: 1px solid #C0C0C0;" \
align="right"><font size="2"></font></th>  <td bgcolor="#c5ffc4" width="50%"><pre \
style="font-size: 8pt; line-height: 140%; margin: 0; "></pre></td>  <th \
bgcolor="#b1ebb0" style="border-left: 1px solid #C0C0C0; border-right: 1px solid \
#C0C0C0;" align="right"><font size="2">316</font></th>  <td bgcolor="#c5ffc4" \
width="50%"><pre style="font-size: 8pt; line-height: 140%; margin: 0; ">    <span \
class="k">if</span> <span class="p">(</span><span class="n">m_type</span> <span \
class="o">==</span> <span class="n">BouncingFeedback</span><span class="p">)</span> \
<span class="c1">// get ratio for bouncing cursor so we don&#39;t need to manually \
calculate the sizes for each icon size</span></pre></td>  </tr>

 </tbody>

</table>

  <pre style="white-space: pre-wrap; white-space: -moz-pre-wrap; white-space: \
-pre-wrap; white-space: -o-pre-wrap; word-wrap: break-word;">m_boucingSizesRatio is \
only conditionally initialized (ie. &quot;else m_boucingSizesRatio = \
1.0;&quot;)</pre>  </blockquote>





</blockquote>
<pre style="margin-left: 1em; white-space: pre-wrap; white-space: -moz-pre-wrap; \
white-space: -pre-wrap; white-space: -o-pre-wrap; word-wrap: break-word;">I actually \
only if&#39;d it out because I feared it might be a heavy operation. Is it okay to \
always call that function?</pre> <br />




<p>- Kai Uwe</p>


<br />
<p>On August 24th, 2012, 3:32 p.m., Kai Uwe Broulik wrote:</p>






<table bgcolor="#fefadf" width="100%" cellspacing="0" cellpadding="8" \
style="background-image: \
url('http://git.reviewboard.kde.org/media/rb/images/review_request_box_top_bg.png'); \
background-position: left top; background-repeat: repeat-x; border: 1px black \
solid;">  <tr>
  <td>

<div>Review request for kwin.</div>
<div>By Kai Uwe Broulik.</div>


<p style="color: grey;"><i>Updated Aug. 24, 2012, 3:32 p.m.</i></p>






<h1 style="color: #575012; font-size: 10pt; margin-top: 1.5em;">Description </h1>
 <table width="100%" bgcolor="#ffffff" cellspacing="0" cellpadding="10" \
style="border: 1px solid #b8b5a0">  <tr>
  <td>
   <pre style="margin: 0; padding: 0; white-space: pre-wrap; white-space: \
-moz-pre-wrap; white-space: -pre-wrap; white-space: -o-pre-wrap; word-wrap: \
break-word;">This patch makes KWin's startup feedback effect aka bouncing cursor \
respect the global small icon size. The icon was loaded correctly but scaled to a \
fixed size previously. (The variable could be given a better name for sure)</pre>
  </td>
 </tr>
</table>


<h1 style="color: #575012; font-size: 10pt; margin-top: 1.5em;">Testing </h1>
<table width="100%" bgcolor="#ffffff" cellspacing="0" cellpadding="10" style="border: \
1px solid #b8b5a0">  <tr>
  <td>
   <pre style="margin: 0; padding: 0; white-space: pre-wrap; white-space: \
-moz-pre-wrap; white-space: -pre-wrap; white-space: -o-pre-wrap; word-wrap: \
break-word;">Tested with 16, 22 and 48 icon size and works fine.</pre>  </td>
 </tr>
</table>



<div style="margin-top: 1.5em;">
 <b style="color: #575012; font-size: 10pt; margin-top: 1.5em;">Bugs: </b>


 <a href="http://bugs.kde.org/show_bug.cgi?id=305611">305611</a>


</div>


<h1 style="color: #575012; font-size: 10pt; margin-top: 1.5em;">Diffs</b> </h1>
<ul style="margin-left: 3em; padding-left: 0;">

 <li>kwin/effects/startupfeedback/startupfeedback.h <span style="color: \
grey">(6758354)</span></li>

 <li>kwin/effects/startupfeedback/startupfeedback.cpp <span style="color: \
grey">(ff6a51e)</span></li>

</ul>

<p><a href="http://git.reviewboard.kde.org/r/106166/diff/" style="margin-left: \
3em;">View Diff</a></p>




  </td>
 </tr>
</table>








  </div>
 </body>
</html>



_______________________________________________
kwin mailing list
kwin@kde.org
https://mail.kde.org/mailman/listinfo/kwin


[prev in list] [next in list] [prev in thread] [next in thread] 

Configure | About | News | Add a list | Sponsored by KoreLogic