[prev in list] [next in list] [prev in thread] [next in thread] 

List:       kwin
Subject:    Re: Review Request: Extend quicktiling to tile windows on quarter of
From:       Thomas_Lübking <thomas.luebking () web ! de>
Date:       2010-10-24 17:53:57
Message-ID: 20101024175357.18589.7195 () vidsolbach ! de
[Download RAW message or body]

[Attachment #2 (multipart/alternative)]


-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
http://svn.reviewboard.kde.org/r/5661/#review8337
-----------------------------------------------------------



trunk/KDE/kdebase/workspace/kwin/events.cpp
<http://svn.reviewboard.kde.org/r/5661/#comment8613>

    This could probably be condensed by using flags instead of enums and i'd cache \
the screen->geom() in some QRect &geo for readability



trunk/KDE/kdebase/workspace/kwin/lib/kwinglobals.h
<http://svn.reviewboard.kde.org/r/5661/#comment8614>

    Not so much about /this/ diff, but do we really need both enums?
    They look quite redundant =\
    
    (but i admit that i didn't fully read the code)


- Thomas


On 2010-10-19 20:09:07, Arthur Arlt wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> http://svn.reviewboard.kde.org/r/5661/
> -----------------------------------------------------------
> 
> (Updated 2010-10-19 20:09:07)
> 
> 
> Review request for kwin and Martin Gräßlin.
> 
> 
> Summary
> -------
> 
> This is my first contribution to an open source project. I like the quick tiling \
> functionality in kwin and I use it quite often. But sometimes there is no need to \
> tile a window to the whole half of a screen. It is absolutely sufficient to tile \
> some windows to a quarter of the screen, for example a chat window or konsole \
> windows. 
> My idea was to reserve the upper and lower quater of the left/right screen edge to \
> tile a windows to the appropriate quater. The remaining part in the middle is \
> triggering the existing functionality, that is maximizing to the half of the \
> screen. 
> The upper screen edge is not changed by this patch.
> 
> Note: This patch has already been pre-reviewed by my room mate Martin Gräßlin, \
> who was helping me to find the actual parts in the code. 
> 
> Diffs
> -----
> 
> trunk/KDE/kdebase/workspace/kwin/events.cpp 1169611 
> trunk/KDE/kdebase/workspace/kwin/geometry.cpp 1169611 
> trunk/KDE/kdebase/workspace/kwin/lib/kwinglobals.h 1169611 
> 
> Diff: http://svn.reviewboard.kde.org/r/5661/diff
> 
> 
> Testing
> -------
> 
> Tested only on my Laptop, running there stable for some weeks. Not tested for multi \
> screen setups. 
> 
> Thanks,
> 
> Arthur
> 
> 


[Attachment #5 (text/html)]

<html>
 <body>
  <div style="font-family: Verdana, Arial, Helvetica, Sans-Serif;">
   <table bgcolor="#f9f3c9" width="100%" cellpadding="8" style="border: 1px #c9c399 \
solid;">  <tr>
     <td>
      This is an automatically generated e-mail. To reply, visit:
      <a href="http://svn.reviewboard.kde.org/r/5661/">http://svn.reviewboard.kde.org/r/5661/</a>
  </td>
    </tr>
   </table>
   <br />









<div>




<table width="100%" border="0" bgcolor="white" style="border: 1px solid #C0C0C0; \
border-collapse: collapse; margin: 2px padding: 2px;">  <thead>
  <tr>
   <th colspan="4" bgcolor="#F0F0F0" style="border-bottom: 1px solid #C0C0C0; \
font-size: 9pt; padding: 4px 8px; text-align: left;">  <a \
href="http://svn.reviewboard.kde.org/r/5661/diff/1/?file=39754#file39754line1462" \
style="color: black; font-weight: bold; text-decoration: \
underline;">trunk/KDE/kdebase/workspace/kwin/events.cpp</a>  <span \
style="font-weight: normal;">

     (Diff revision 1)

    </span>
   </th>
  </tr>
 </thead>

 <tbody style="background-color: #e4d9cb; padding: 4px 8px; text-align: center;">
  <tr>

   <td colspan="4"><pre style="font-size: 8pt; line-height: 140%; margin: 0; ">void \
Client::checkQuickTilingMaximizationZones( int xroot, int yroot )</pre></td>

  </tr>
 </tbody>




 
 



 <tbody>

  <tr>
    <th bgcolor="#b1ebb0" style="border-right: 1px solid #C0C0C0;" \
align="right"><font size="2"></font></th>  <td bgcolor="#c5ffc4" width="50%"><pre \
style="font-size: 8pt; line-height: 140%; margin: 0; "></pre></td>  <th \
bgcolor="#b1ebb0" style="border-left: 1px solid #C0C0C0; border-right: 1px solid \
#C0C0C0;" align="right"><font size="2">1462</font></th>  <td bgcolor="#c5ffc4" \
width="50%"><pre style="font-size: 8pt; line-height: 140%; margin: 0; ">              \
<span class="n">yroot</span> <span class="o">&lt;=</span> <span \
class="n">screen</span><span class="o">-&gt;</span><span class="n">geom</span><span \
class="p">().</span><span class="n">y</span><span class="p">()</span> <span \
class="o">+</span> <span class="n">screen</span><span class="o">-&gt;</span><span \
class="n">geom</span><span class="p">().</span><span class="n">height</span><span \
class="p">()</span><span class="o">/</span><span class="mi">4</span> <span \
class="p">)</span></pre></td>  </tr>

 </tbody>

</table>

<pre style="margin-left: 2em; white-space: pre-wrap; white-space: -moz-pre-wrap; \
white-space: -pre-wrap; white-space: -o-pre-wrap; word-wrap: break-word;">This could \
probably be condensed by using flags instead of enums and i&#39;d cache the \
screen-&gt;geom() in some QRect &amp;geo for readability</pre> </div>
<br />

<div>




<table width="100%" border="0" bgcolor="white" style="border: 1px solid #C0C0C0; \
border-collapse: collapse; margin: 2px padding: 2px;">  <thead>
  <tr>
   <th colspan="4" bgcolor="#F0F0F0" style="border-bottom: 1px solid #C0C0C0; \
font-size: 9pt; padding: 4px 8px; text-align: left;">  <a \
href="http://svn.reviewboard.kde.org/r/5661/diff/1/?file=39756#file39756line91" \
style="color: black; font-weight: bold; text-decoration: \
underline;">trunk/KDE/kdebase/workspace/kwin/lib/kwinglobals.h</a>  <span \
style="font-weight: normal;">

     (Diff revision 1)

    </span>
   </th>
  </tr>
 </thead>

 <tbody style="background-color: #e4d9cb; padding: 4px 8px; text-align: center;">
  <tr>

   <td colspan="4"><pre style="font-size: 8pt; line-height: 140%; margin: 0; ">enum \
ElectricBorder</pre></td>

  </tr>
 </tbody>




 
 



 <tbody>

  <tr>
    <th bgcolor="#b1ebb0" style="border-right: 1px solid #C0C0C0;" \
align="right"><font size="2"></font></th>  <td bgcolor="#c5ffc4" width="50%"><pre \
style="font-size: 8pt; line-height: 140%; margin: 0; "></pre></td>  <th \
bgcolor="#b1ebb0" style="border-left: 1px solid #C0C0C0; border-right: 1px solid \
#C0C0C0;" align="right"><font size="2">91</font></th>  <td bgcolor="#c5ffc4" \
width="50%"><pre style="font-size: 8pt; line-height: 140%; margin: 0; ">    <span \
class="n">QuickTileTopLeft</span><span class="p">,</span></pre></td>  </tr>

 </tbody>

</table>

<pre style="margin-left: 2em; white-space: pre-wrap; white-space: -moz-pre-wrap; \
white-space: -pre-wrap; white-space: -o-pre-wrap; word-wrap: break-word;">Not so much \
about /this/ diff, but do we really need both enums? They look quite redundant =\

(but i admit that i didn&#39;t fully read the code)</pre>
</div>
<br />



<p>- Thomas</p>


<br />
<p>On October 19th, 2010, 8:09 p.m., Arthur Arlt wrote:</p>






<table bgcolor="#fefadf" width="100%" cellspacing="0" cellpadding="8" \
style="background-image: \
url('http://svn.reviewboard.kde.orgrb/images/review_request_box_top_bg.png'); \
background-position: left top; background-repeat: repeat-x; border: 1px black \
solid;">  <tr>
  <td>

<div>Review request for kwin and Martin Gräßlin.</div>
<div>By Arthur Arlt.</div>


<p style="color: grey;"><i>Updated 2010-10-19 20:09:07</i></p>




<h1 style="color: #575012; font-size: 10pt; margin-top: 1.5em;">Description </h1>
<table width="100%" bgcolor="#ffffff" cellspacing="0" cellpadding="10" style="border: \
1px solid #b8b5a0">  <tr>
  <td>
   <pre style="margin: 0; padding: 0; white-space: pre-wrap; white-space: \
-moz-pre-wrap; white-space: -pre-wrap; white-space: -o-pre-wrap; word-wrap: \
break-word;">This is my first contribution to an open source project. I like the \
quick tiling functionality in kwin and I use it quite often. But sometimes there is \
no need to tile a window to the whole half of a screen. It is absolutely sufficient \
to tile some windows to a quarter of the screen, for example a chat window or konsole \
windows.

My idea was to reserve the upper and lower quater of the left/right screen edge to \
tile a windows to the appropriate quater. The remaining part in the middle is \
triggering the existing functionality, that is maximizing to the half of the screen.

The upper screen edge is not changed by this patch.

Note: This patch has already been pre-reviewed by my room mate Martin Gräßlin, who \
was helping me to find the actual parts in the code.</pre>  </td>
 </tr>
</table>


<h1 style="color: #575012; font-size: 10pt; margin-top: 1.5em;">Testing </h1>
<table width="100%" bgcolor="#ffffff" cellspacing="0" cellpadding="10" style="border: \
1px solid #b8b5a0">  <tr>
  <td>
   <pre style="margin: 0; padding: 0; white-space: pre-wrap; white-space: \
-moz-pre-wrap; white-space: -pre-wrap; white-space: -o-pre-wrap; word-wrap: \
break-word;">Tested only on my Laptop, running there stable for some weeks. Not \
tested for multi screen setups.</pre>  </td>
 </tr>
</table>




<h1 style="color: #575012; font-size: 10pt; margin-top: 1.5em;">Diffs</b> </h1>
<ul style="margin-left: 3em; padding-left: 0;">

 <li>trunk/KDE/kdebase/workspace/kwin/events.cpp <span style="color: \
grey">(1169611)</span></li>

 <li>trunk/KDE/kdebase/workspace/kwin/geometry.cpp <span style="color: \
grey">(1169611)</span></li>

 <li>trunk/KDE/kdebase/workspace/kwin/lib/kwinglobals.h <span style="color: \
grey">(1169611)</span></li>

</ul>

<p><a href="http://svn.reviewboard.kde.org/r/5661/diff/" style="margin-left: \
3em;">View Diff</a></p>




  </td>
 </tr>
</table>








  </div>
 </body>
</html>



_______________________________________________
kwin mailing list
kwin@kde.org
https://mail.kde.org/mailman/listinfo/kwin


[prev in list] [next in list] [prev in thread] [next in thread] 

Configure | About | News | Add a list | Sponsored by KoreLogic