--===============2084144591== Content-Type: multipart/signed; boundary="nextPart1568574.VYVfWoVxMf"; protocol="application/pgp-signature"; micalg=pgp-sha1 Content-Transfer-Encoding: 7bit --nextPart1568574.VYVfWoVxMf Content-Type: text/plain; charset="us-ascii" Content-Transfer-Encoding: quoted-printable Content-Disposition: inline hi, here my changes I would like to do in a while: a) convert use of unsigned int to int, as QT has changed to use int in near= ly all places, it atm is a hassle to convert back to int in all loops, length compares and lookups, should m= ake code more readable I guess b) add an interface for some kind of "editor factory" or how ever to call it this will just a plain QObject which lets you create KTextEditor::Docum= ents, it will avoid the current hassle in kate to have around one global object for ever and speed up document= creation for apps using it, if the app devs still use the old way, nothing will break, but this wi= ll give a faster way ;) c) remove the DCOP interfaces from the lib, really, this should be done per= part, the current overhead of 10000ths interfaces isn't worth the hassle, and it will save us from the= need for dpointers in the interfaces and the duplicated ints all over, only the document and view itself should p= rovide some number to the outside to make handling easier ;) btw., perhaps should the int method just be part of i= nterface and the implementation part should take the effort to make it unique, in the mini implementation it would l= ook like the current in ktexteditor, but I think the interfaces should really be without any implementation at all inside d) some little conflict solving and removing: - KTextEditor::Editor -> CU, this is the no view/doc seperation thing, i= t's just not needed any more, yzis/kate supports it, and it's not that nice as the static queryMetho= des don't cover it and it's a hack, away :) - SessionConfigInterface and ConfigInterface overlap, the readSessionCon= fig... should be removed from ConfigInterface - CursorInterface: not sure, wasn't that usable in the current state, pe= rhaps we should remove this now, and readd later a usable one, if we have all come up with one ;) - DynWordWrapInterface -> TRASH, not needed, this is part internal stuff,= why should host app want to enforce that, bypassing the users config, it has no effect on text content, not like = the static word wrap, which might be needed to enforce ;) - PrintInterface -> CU, user action, too - UndoInterface -> CU, user action, too, + config stuff - ViewStatusMsgInterface -> CU, this contains only one signal, and is not= that usable at all, as nobody knows whats in this, if we really need this, we should note down in the KTextEditor::V= iew which "non-interface" related signals parts should provide, just some comment would be sufficient, as this signal c= onnection is nothing we do at compile time e) merge some of the interfaces, which will avoid the current blow up of th= em ;) - EditInterface + Ext -> EditInterface, the editBegin()/editEnd() transa= ction methodes won't hurt to be in the basic editing interface, if the part doesn't support it, it should just do n= othing there :) - selection interface + ext + blockselection interface -> SelectionInte= rface + this is FOR VIEW this time ;) - Clipboard Interface -> SelectionInterface, as this is for VIEW, too, a= nd selection is per view, makes sense to collect this selection related 2 methodes in the SelectionInterface= , too, no need for seperate, each editor supporting selection should have no probs with copy/paste/cut a= nd co, not even sure if anybody uses this, but hey, if this are just 3 methodes in a interface, this w= on't hurt, if it stays seperate, it will ;) - ConfigInterface + ConfigInterfaceExtension, simple merge, guess after t= he conversion to int, the configPages() counter should just return -1 if this part doesn't allow to emebed ind= ividual config pages ;) - MarkInterface + Extension -> MarkInterface - ViewCursorInterface -> CursorInterface, makes no sense to prefix, this = is for view just, and good ;) if ever a other cursor interface for editing purpose comes up, this sho= uld be EditCursor or CursorEdit or whatever This would be all cleanup changes I have to propose ATM, this doesn't reall= y change any function, just cleaning up the stuff, which has grown to some lets say "not that small" amount ;) cu Christoph =2D-=20 Christoph Cullmann KDE Developer, kde.org Maintainance Team http://www.babylon2k.de, cullmann@kde.org --nextPart1568574.VYVfWoVxMf Content-Type: application/pgp-signature -----BEGIN PGP SIGNATURE----- Version: GnuPG v1.2.5 (GNU/Linux) iD8DBQBClu8MyPjDGePm9UIRAkalAKCkJsuBn1XHzqqBNg3W4m30hfYrQgCcCyb6 ABWZ7CYdk2G1Mbg2kg2XK5A= =eKAp -----END PGP SIGNATURE----- --nextPart1568574.VYVfWoVxMf-- --===============2084144591== Content-Type: text/plain; charset="us-ascii" MIME-Version: 1.0 Content-Transfer-Encoding: 7bit Content-Disposition: inline _______________________________________________ Ktexteditor-devel mailing list Ktexteditor-devel@kde.org https://mail.kde.org/mailman/listinfo/ktexteditor-devel --===============2084144591==--