The amount of duplicated code that it introduces in every protocol is what makes me nervous. Something I spotted: - validateData in Kopete"s ediitaccountwidget is pure virtual - it is reimplemented by protocols, same with validatePassword What I suggest: - rename validateData to validateProtocolData (or just validateData), as virtual make some method in the editaccountwidget (validateData or something else?) non virtual, put the duplicated account code there, and call the virtuals validateProtocolData (or validateData if it is the name) and validatePassword as decorator methods. Duncan _______________________________________________ kopete-devel mailing list kopete-devel@kde.org https://mail.kde.org/mailman/listinfo/kopete-devel