From koffice-devel Sun May 09 20:34:31 2004 From: David Faure Date: Sun, 09 May 2004 20:34:31 +0000 To: koffice-devel Subject: Re: [PATCH] koffice and gcc 3.4 fix Message-Id: <200405092234.32038.faure () kde ! org> X-MARC-Message: https://marc.info/?l=koffice-devel&m=108413487920162 On Sunday 09 May 2004 21:13, Piotr Szymanski wrote: > Hi, > As in $subject: > http://cvs.pld-linux.org/cgi-bin/cvsweb/SOURCES/koffice-gcc34.patch - KoRect rect( rect().x(), rect().y(), rect().width(), rect().height() ); + KoRect rect( rect.x(), rect.y(), rect.width(), rect.height() ); This looks incorrect to me (it uses the member methods of the same variable as the one it's currently initializing!). Better rename the variable. Hmm, or even better, this looks like QRect->KoRect conversion, so it should be KoRect rect = KoRect::fromQRect( this->rect() ); Does that work? -- David Faure, faure@kde.org, sponsored by Trolltech to work on KDE, Konqueror (http://www.konqueror.org), and KOffice (http://www.koffice.org). _______________________________________________ koffice-devel mailing list koffice-devel@mail.kde.org https://mail.kde.org/mailman/listinfo/koffice-devel