On Friday 06 June 2003 02:10, Dawit A. wrote: > Hello, > > Here is a patch that does the following: > > - Properly Initialize m_port. > > - Split out the macro (.netrc) based login into its own function: > ftpAutoLoginMacro. > > - Cleanup how login information (username and password) including the default > once are used. Ok, but why did you sneak in this kind of change? - infoMessage( i18n("Opening connection to host %1").arg(m_host) ); + infoMessage( i18n("Opening connection to host %1").arg(m_host) ); Did we decide against hostnames in bold? This kind of "cleanup" doesn't really improve readability either: - if ( m_host != _host || m_port != _port || - m_user != user || m_pass != pass ) + if ( (m_host != _host) || (m_port != _port ) || + (m_user != _user) || (m_pass != _pass) ) > - Enable kio_ftp to work with ftp servers that do not allow anonymous users > and close such connection immediately. The pure-ftpd server which I use is a > prime example of this. To fix this I basically changed how ftpSendCmd works > and made it more tolerant. It now retries to send the command at least one > more time if it fails because the connection timed-out or there was an error > when writting to the socket. I remember this stuff being quite touchy. Did you test a few sites that time out? > - Move "the too many users" error message handling to where it belongs. Down > in the ::connect function. That function now simply sends back the message > its receives from the server if the connection did not succeed. It is then up > to the user to retry the connection (e.g. by simply pressing reload button in > konqy). Sounds good. -- David FAURE, faure@kde.org, sponsored by Trolltech to work on KDE, Konqueror (http://www.konqueror.org), and KOffice (http://www.koffice.org). Qtella users - stability patches at http://blackie.dk/~dfaure/qtella.html