[prev in list] [next in list] [prev in thread] [next in thread] 

List:       kdevelop-bugs
Subject:    [Bug 255706] New: KDevelop does not rename a variable in method
From:       Nathan <digitalpioneer () gmail ! com>
Date:       2010-10-30 22:41:46
Message-ID: bug-255706-40295 () http ! bugs ! kde ! org/
[Download RAW message or body]

https://bugs.kde.org/show_bug.cgi?id=255706

           Summary: KDevelop does not rename a variable in method
                    declaration, definition, and function body
           Product: kdevelop
           Version: 4.1.60
          Platform: Archlinux Packages
        OS/Version: Linux
            Status: UNCONFIRMED
          Severity: minor
          Priority: NOR
         Component: Language Support: CPP
        AssignedTo: kdevelop-bugs@kdevelop.org
        ReportedBy: digitalpioneer@gmail.com


Version:           4.1.60 (using KDE 4.5.2) 
OS:                Linux

Say you make a method Bar(int baz) on object Foo. foo.h contains the prototype:
Bar(int baz);
And foo.cpp contains the definition:
Foo::Bar(int baz) {do_stuff(baz);}

Now, change the name of baz to Baz in the prototype, and KDevelop helpfully
offers to change it in the definition as well. Tell it to do so, and it will
change the definition to:
Foo::Bar(int Baz) {do_stuff(baz);}
It did not change the name in the body of the function, only the parameter
list.

Now, instead of renaming it in the prototype, rename it in the definition.
KDevelop again offers to rename it, so let it do so, and it renames it in the
function body, but not in the prototype in the header.

Obviously, renamed variables should be synced across the parameter list in the
prototype, definition and function body.

Reproducible: Always

-- 
Configure bugmail: https://bugs.kde.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.

_______________________________________________
KDevelop-bugs mailing list
KDevelop-bugs@kdevelop.org
https://barney.cs.uni-potsdam.de/mailman/listinfo/kdevelop-bugs
[prev in list] [next in list] [prev in thread] [next in thread] 

Configure | About | News | Add a list | Sponsored by KoreLogic