From kde-panel-devel Sun Sep 26 20:27:57 2010 From: "Aaron Seigo" Date: Sun, 26 Sep 2010 20:27:57 +0000 To: kde-panel-devel Subject: Re: Review Request: Cleanups in pager Message-Id: <20100926202757.13966.36906 () vidsolbach ! de> X-MARC-Message: https://marc.info/?l=kde-panel-devel&m=128553290311368 MIME-Version: 1 Content-Type: multipart/mixed; boundary="--===============0433966533==" --===============0433966533== Content-Type: multipart/alternative; boundary="===============1043526670688062372==" --===============1043526670688062372== Content-Type: text/plain; charset="utf-8" MIME-Version: 1.0 Content-Transfer-Encoding: quoted-printable ----------------------------------------------------------- This is an automatically generated e-mail. To reply, visit: http://svn.reviewboard.kde.org/r/5355/#review7825 ----------------------------------------------------------- Ship it! - Aaron On 2010-09-24 23:59:14, Anthony Bryant wrote: > = > ----------------------------------------------------------- > This is an automatically generated e-mail. To reply, visit: > http://svn.reviewboard.kde.org/r/5355/ > ----------------------------------------------------------- > = > (Updated 2010-09-24 23:59:14) > = > = > Review request for Plasma. > = > = > Summary > ------- > = > * Make configAccepted() just write the new config, and make configChanged= () conditionally update the plasmoid after reading the config back in. > * Split the grid resizing logic into its own method: recalculateGridSizes= (int rows), and make it detect more edge cases. > * Rename the main size calculation method to updateSizes(bool allowResize= ), which will resize the applet to its preferred size if allowResize is tru= e. > * Fix a bug which caused applet resizes to be wrongly cancelled in some s= ituations. > * Code style cleanups, remove unused variables, etc. > = > (Sorry for putting so many changes into one patch) > = > = > This addresses bug 250756. > https://bugs.kde.org/show_bug.cgi?id=3D250756 > = > = > Diffs > ----- > = > /trunk/KDE/kdebase/workspace/plasma/desktop/applets/pager/pager.h 11792= 62 = > /trunk/KDE/kdebase/workspace/plasma/desktop/applets/pager/pager.cpp 117= 9262 = > = > Diff: http://svn.reviewboard.kde.org/r/5355/diff > = > = > Testing > ------- > = > Tested configuring the pager from the config interface and the desktop co= nsole, and that it responds correctly to changes in desktop count, and in F= ormFactor and size. > = > = > Thanks, > = > Anthony > = > --===============1043526670688062372== Content-Type: text/html; charset="utf-8" MIME-Version: 1.0 Content-Transfer-Encoding: quoted-printable
This is an automatically generated e-mail. To reply, visit: http://svn.reviewb= oard.kde.org/r/5355/

Ship it!

- Aaron


On September 24th, 2010, 11:59 p.m., Anthony Bryant wrote:

Review request for Plasma.
By Anthony Bryant.

Updated 2010-09-24 23:59:14

Descripti= on

* Make configAccepted() just write the new config, and make =
configChanged() conditionally update the plasmoid after reading the config =
back in.
* Split the grid resizing logic into its own method: recalculateGridSizes(i=
nt rows), and make it detect more edge cases.
* Rename the main size calculation method to updateSizes(bool allowResize),=
 which will resize the applet to its preferred size if allowResize is true.
* Fix a bug which caused applet resizes to be wrongly cancelled in some sit=
uations.
* Code style cleanups, remove unused variables, etc.

(Sorry for putting so many changes into one patch)

Testing <= /h1>
Tested configuring the pager from the config interface and t=
he desktop console, and that it responds correctly to changes in desktop co=
unt, and in FormFactor and size.
Bugs: 250756

Diffs=

  • /trunk/KDE/kdebase/workspace/plasma/desktop/applets/pager/pager.h (1179262)
  • /trunk/KDE/kdebase/workspace/plasma/desktop/applets/pager/pager.cpp (1179262)

View Diff

--===============1043526670688062372==-- --===============0433966533== Content-Type: text/plain; charset="us-ascii" MIME-Version: 1.0 Content-Transfer-Encoding: 7bit Content-Disposition: inline _______________________________________________ Plasma-devel mailing list Plasma-devel@kde.org https://mail.kde.org/mailman/listinfo/plasma-devel --===============0433966533==--