[prev in list] [next in list] [prev in thread] [next in thread] 

List:       kde-multimedia
Subject:    Re: [Phonon][Patch] add a method to get the current frame number
From:       "Tanguy Krotoff" <tkrotoff () gmail ! com>
Date:       2008-03-28 1:23:51
Message-ID: 129f18a00803271823h2d3bf314j82f0991d37de218b () mail ! gmail ! com
[Download RAW message or body]

On Thu, Mar 20, 2008 at 7:40 PM, Matthias Kretz <kretz@kde.org> wrote:
>  Perhaps it should be called currentVideoFrame() since there are also audio
>  frames (just 48000 per second instead of ~25). And I omitted "Number" to not
>  make the function name too long.

I think term Number is good since currentVideoFrame() can "mean" something else
like:
qint64 videoFrameId = obj->currentVideoFrame();
or
VideoFrame videoFrame = obj->currentVideoFrame();
videoFrame->size();

Why not Nb?
Number is used by Qt API, not Nb
cf http://doc.trolltech.com/main-snapshot/functions.html

>  Other functions that could be added later are:
>  qint64 videoFrameCount()
>  void seekToVideoFrame(qint64)

seekToVideoFrameNumber()
to make it symmetric, even a longer name :/

-- 
Tanguy Krotoff <tkrotoff@gmail.com>
+33 6 68 42 70 24
_______________________________________________
kde-multimedia mailing list
kde-multimedia@kde.org
https://mail.kde.org/mailman/listinfo/kde-multimedia
[prev in list] [next in list] [prev in thread] [next in thread] 

Configure | About | News | Add a list | Sponsored by KoreLogic