[prev in list] [next in list] [prev in thread] [next in thread] 

List:       kde-i18n
Subject:    Re: draft+thoughts
From:       David Faure <David.Faure () insa-lyon ! fr>
Date:       1999-02-22 22:56:03
[Download RAW message or body]

On Sat, Feb 20, 1999 at 10:24:57PM +0100, Simon Hausmann wrote:
> Hi,
> 
> I finished writing a draft of the new Konqueror interfaces and I tried to
> explain some things in regard to the a-common-gui-for-Konqueror problem.
> 
> Please let me know what you think of it, what you think is perhaps missing or
> what is actually wrong (it can be easily possible that I forgot something or
> there's a fundamental error in my thoughts).

I don't understand the difference you make between GUI and MainWindow.
As I understand it, in a konqueror process (application), there can be
several windows. Calling it MainWindow is just a sight of the mind. BTW,
koffice calls MainWindow every window, even if you have several windows in
e.g. kword. So a GUI (in kfm) is a MainWindow (in konqueror). I would
remove any instance of the word and the concept of GUI. In KDE, everything
is a GUI :)

You wrote :
  interface GUI : KOM::Base
  {
    void setGUIPart( in OpenParts::Part part );
 
    void addGUIClient( in View view );
    void removeGUIClient( in View view );
  };    

  [...]

  interface MainWindow : OpenParts::MainWindow
  {
  }; 

  interface Application : OpenParts::Application
  {
    GUI createKonquerorGUI();
 
    MainView createMainView();
    IconView createIconView();
    HTMLView createHTMLView();
    TreeView createTreeView();
    PartView createPartView();
  };


Why not make it the following ?

  interface MainWindow : OpenParts::MainWindow
  {
    void setPart( in OpenParts::Part part );
 
    void addClient( in View view );
    void removeClient( in View view );
  }; 

  interface Application : OpenParts::Application
  {
    MainWindow createKonquerorWindow();
 
    MainView createMainView();
    IconView createIconView();
    HTMLView createHTMLView();
    TreeView createTreeView();
    PartView createPartView();
  };


Hum, I think I'm wrong here - you speak about the GUI interface quite a lot 
in your INTERNALS document. So the concept might be needed, but I miss its
definition, probably missing a better name for it.

As I see it, there are
* views inside a MainWindow inside the konqueror application, 
* views inside another MainWindow, inside another application. 
Where does the concept of GUI comes into this ?

Thanks for your lights :)

-- 
 ____________________________________________________________________
|                                                                    |
|  David FAURE                                                       |
|  E-mail : David.Faure@insa-lyon.fr, faure@kde.org                  |
|  http://www.insa-lyon.fr/People/AEDI/dfaure/index.html             |
|____________________________________________________________________|

[prev in list] [next in list] [prev in thread] [next in thread] 

Configure | About | News | Add a list | Sponsored by KoreLogic