[prev in list] [next in list] [prev in thread] [next in thread] 

List:       kde-hardware-devel
Subject:    Re: [Kde-hardware-devel] Review Request 117339: Add timeToFull/timeToEmpty, recall notice and FullyC
From:       "Kevin Ottens" <ervin () kde ! org>
Date:       2014-07-03 6:22:08
Message-ID: 20140703062208.32416.23260 () probe ! kde ! org
[Download RAW message or body]

[Attachment #2 (multipart/alternative)]


-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://git.reviewboard.kde.org/r/117339/#review61520
-----------------------------------------------------------


Note we had a major failure on this particular review as it changed some backend API \
but didn't adjust win or iokit backends. Those ones are likely broken since it got \
in.

- Kevin Ottens


On June 5, 2014, 10:24 a.m., Kai Uwe Broulik wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://git.reviewboard.kde.org/r/117339/
> -----------------------------------------------------------
> 
> (Updated June 5, 2014, 10:24 a.m.)
> 
> 
> Review request for Solid and Àlex Fiestas.
> 
> 
> Repository: solid
> 
> 
> Description
> -------
> 
> This adds the following functionality to Solid::Battery:
> 
> - timeToFull and timeToEmpty (at the moment provided by PowerDevil but for all \
>                 batteries combined, this patch does it individually for each)
> - rename isPlugged to isPresent (as plugged always confused me - it has nothing to \
> do with whether AC is plugged in but if the battery is "present in its bay", it's \
>                 also the name of the UPower iface)
> - FullyCharged battery state, we cannot rely on the battery being 100%, and since \
>                 the info is provided by UPower (not on HAL), why not use it
> - RecallVendor/RecallUrl when a battery has been recalled by the vendor, currently \
>                 provided/handled by PowerDevil
> - Serial number of the battery
> 
> Sorry for the hard to read patch but I also re-ordered some methods to have the \
> order in all implementations and headers the same. 
> 
> Diffs
> -----
> 
> src/solid/devices/ifaces/battery.h 79e0d60 
> src/solid/devices/frontend/battery.cpp e433582 
> src/solid/devices/frontend/battery.h bbf2201 
> src/solid/devices/backends/upower/upowerbattery.cpp c771f68 
> src/solid/devices/backends/upower/upowerbattery.h 9b49d32 
> src/solid/devices/backends/hal/halbattery.cpp a2ac83d 
> src/solid/devices/backends/hal/halbattery.h 1e60aeb 
> src/solid/devices/backends/fakehw/fakebattery.cpp 9af4c6c 
> src/solid/devices/backends/fakehw/fakebattery.h fdb4bcc 
> 
> Diff: https://git.reviewboard.kde.org/r/117339/diff/
> 
> 
> Testing
> -------
> 
> Compiles, solid-hardware5 details /org/freedesktop/UPower/devices/battery_BAT0 \
> reports: 
> udi = '/org/freedesktop/UPower/devices/battery_BAT0'
> parent = '/org/freedesktop/UPower'  (string)
> vendor = 'ASUSTeK'  (string)
> product = 'UX31-35'  (string)
> description = 'Lithium Ion Battery'  (string)
> Battery.present = true  (bool)
> Battery.type = 'PrimaryBattery'  (0x3)  (enum)
> Battery.chargePercent = 31  (0x1f)  (int)
> Battery.capacity = 83  (0x53)  (int)
> Battery.rechargeable = true  (bool)
> Battery.powerSupply = true  (bool)
> Battery.chargeState = 'Discharging'  (0x2)  (enum)
> Battery.timeToEmpty = 5105  (0x13f1)  (qlonglong)
> Battery.timeToFull = 0  (0x0)  (qlonglong)
> Battery.energy = '13.223'  (string) ? dunno why it says string, it's double \
> everywhere Battery.energyRate = '9.324'  (string) ? same
> Battery.voltage = '7.4'  (string) ? same
> Battery.recalled = false  (bool)
> Battery.recallVendor = ''  (string)
> Battery.recallUrl = ''  (string)
> Battery.serial = ''  (string)
> 
> 
> Thanks,
> 
> Kai Uwe Broulik
> 
> 


[Attachment #5 (text/html)]

<html>
 <body>
  <div style="font-family: Verdana, Arial, Helvetica, Sans-Serif;">
   <table bgcolor="#f9f3c9" width="100%" cellpadding="8" style="border: 1px #c9c399 \
solid;">  <tr>
     <td>
      This is an automatically generated e-mail. To reply, visit:
      <a href="https://git.reviewboard.kde.org/r/117339/">https://git.reviewboard.kde.org/r/117339/</a>
  </td>
    </tr>
   </table>
   <br />





 <pre style="white-space: pre-wrap; white-space: -moz-pre-wrap; white-space: \
-pre-wrap; white-space: -o-pre-wrap; word-wrap: break-word;">Note we had a major \
failure on this particular review as it changed some backend API but didn&#39;t \
adjust win or iokit backends. Those ones are likely broken since it got in.</pre>  \
<br />









<p>- Kevin Ottens</p>


<br />
<p>On June 5th, 2014, 10:24 a.m. UTC, Kai Uwe Broulik wrote:</p>








<table bgcolor="#fefadf" width="100%" cellspacing="0" cellpadding="8" \
style="background-image: \
url('https://git.reviewboard.kde.org/static/rb/images/review_request_box_top_bg.ab6f3b1072c9.png'); \
background-position: left top; background-repeat: repeat-x; border: 1px black \
solid;">  <tr>
  <td>

<div>Review request for Solid and Àlex Fiestas.</div>
<div>By Kai Uwe Broulik.</div>


<p style="color: grey;"><i>Updated June 5, 2014, 10:24 a.m.</i></p>









<div style="margin-top: 1.5em;">
 <b style="color: #575012; font-size: 10pt;">Repository: </b>
solid
</div>


<h1 style="color: #575012; font-size: 10pt; margin-top: 1.5em;">Description </h1>
 <table width="100%" bgcolor="#ffffff" cellspacing="0" cellpadding="10" \
style="border: 1px solid #b8b5a0">  <tr>
  <td>
   <pre style="margin: 0; padding: 0; white-space: pre-wrap; white-space: \
-moz-pre-wrap; white-space: -pre-wrap; white-space: -o-pre-wrap; word-wrap: \
break-word;">This adds the following functionality to Solid::Battery:

- timeToFull and timeToEmpty (at the moment provided by PowerDevil but for all \
                batteries combined, this patch does it individually for each)
- rename isPlugged to isPresent (as plugged always confused me - it has nothing to do \
with whether AC is plugged in but if the battery is &quot;present in its bay&quot;, \
                it&#39;s also the name of the UPower iface)
- FullyCharged battery state, we cannot rely on the battery being 100%, and since the \
                info is provided by UPower (not on HAL), why not use it
- RecallVendor/RecallUrl when a battery has been recalled by the vendor, currently \
                provided/handled by PowerDevil
- Serial number of the battery

Sorry for the hard to read patch but I also re-ordered some methods to have the order \
in all implementations and headers the same.</pre>  </td>
 </tr>
</table>


<h1 style="color: #575012; font-size: 10pt; margin-top: 1.5em;">Testing </h1>
<table width="100%" bgcolor="#ffffff" cellspacing="0" cellpadding="10" style="border: \
1px solid #b8b5a0">  <tr>
  <td>
   <pre style="margin: 0; padding: 0; white-space: pre-wrap; white-space: \
-moz-pre-wrap; white-space: -pre-wrap; white-space: -o-pre-wrap; word-wrap: \
break-word;">Compiles, solid-hardware5 details \
/org/freedesktop/UPower/devices/battery_BAT0 reports:

udi = &#39;/org/freedesktop/UPower/devices/battery_BAT0&#39;
  parent = &#39;/org/freedesktop/UPower&#39;  (string)
  vendor = &#39;ASUSTeK&#39;  (string)
  product = &#39;UX31-35&#39;  (string)
  description = &#39;Lithium Ion Battery&#39;  (string)
  Battery.present = true  (bool)
  Battery.type = &#39;PrimaryBattery&#39;  (0x3)  (enum)
  Battery.chargePercent = 31  (0x1f)  (int)
  Battery.capacity = 83  (0x53)  (int)
  Battery.rechargeable = true  (bool)
  Battery.powerSupply = true  (bool)
  Battery.chargeState = &#39;Discharging&#39;  (0x2)  (enum)
  Battery.timeToEmpty = 5105  (0x13f1)  (qlonglong)
  Battery.timeToFull = 0  (0x0)  (qlonglong)
  Battery.energy = &#39;13.223&#39;  (string) ? dunno why it says string, it&#39;s \
double everywhere  Battery.energyRate = &#39;9.324&#39;  (string) ? same
  Battery.voltage = &#39;7.4&#39;  (string) ? same
  Battery.recalled = false  (bool)
  Battery.recallVendor = &#39;&#39;  (string)
  Battery.recallUrl = &#39;&#39;  (string)
  Battery.serial = &#39;&#39;  (string)</pre>
  </td>
 </tr>
</table>


<h1 style="color: #575012; font-size: 10pt; margin-top: 1.5em;">Diffs</b> </h1>
<ul style="margin-left: 3em; padding-left: 0;">

 <li>src/solid/devices/ifaces/battery.h <span style="color: \
grey">(79e0d60)</span></li>

 <li>src/solid/devices/frontend/battery.cpp <span style="color: \
grey">(e433582)</span></li>

 <li>src/solid/devices/frontend/battery.h <span style="color: \
grey">(bbf2201)</span></li>

 <li>src/solid/devices/backends/upower/upowerbattery.cpp <span style="color: \
grey">(c771f68)</span></li>

 <li>src/solid/devices/backends/upower/upowerbattery.h <span style="color: \
grey">(9b49d32)</span></li>

 <li>src/solid/devices/backends/hal/halbattery.cpp <span style="color: \
grey">(a2ac83d)</span></li>

 <li>src/solid/devices/backends/hal/halbattery.h <span style="color: \
grey">(1e60aeb)</span></li>

 <li>src/solid/devices/backends/fakehw/fakebattery.cpp <span style="color: \
grey">(9af4c6c)</span></li>

 <li>src/solid/devices/backends/fakehw/fakebattery.h <span style="color: \
grey">(fdb4bcc)</span></li>

</ul>

<p><a href="https://git.reviewboard.kde.org/r/117339/diff/" style="margin-left: \
3em;">View Diff</a></p>







  </td>
 </tr>
</table>








  </div>
 </body>
</html>



_______________________________________________
Kde-hardware-devel mailing list
Kde-hardware-devel@kde.org
https://mail.kde.org/mailman/listinfo/kde-hardware-devel


[prev in list] [next in list] [prev in thread] [next in thread] 

Configure | About | News | Add a list | Sponsored by KoreLogic