[prev in list] [next in list] [prev in thread] [next in thread] 

List:       kde-games-devel
Subject:    Re: [Kde-games-devel] Review Request: Hint in Kiriki
From:       "Parker Coates" <parker.coates () kdemail ! net>
Date:       2010-05-11 19:46:44
Message-ID: 20100511194644.22502.44813 () localhost
[Download RAW message or body]


-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
http://reviewboard.kde.org/r/3793/#review5606
-----------------------------------------------------------



/trunk/KDE/kdegames/kiriki/src/kiriki.cpp
<http://reviewboard.kde.org/r/3793/#comment5305>

    When the body of a loop or condition is more than one line, I would highly \
recommend adding curly braces around it. In a case like this, somebody might try to \
add code to the loop by inserting a statement before the "if", accidentally "bumping" \
the "if" outside the "for" in the process. These things can be really nasty to debug.



/trunk/KDE/kdegames/kiriki/src/scores.cpp
<http://reviewboard.kde.org/r/3793/#comment5306>

    Returning a pointer to an internal array is kind of nasty as there's no bounds \
checking. A safer (and more readable) design would be to replace this method with a \
"QString playName(int index) const" method.


- Parker


On 2010-05-01 04:04:26, Luiz Romário Santana Rios wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> http://reviewboard.kde.org/r/3793/
> -----------------------------------------------------------
> 
> (Updated 2010-05-01 04:04:26)
> 
> 
> Review request for KDE Games.
> 
> 
> Summary
> -------
> 
> This patch implements hint in Kiriki, using the computer itself to give it. The \
> tips are shown in the status bar - that is hidden right after the roll. 
> 
> Diffs
> -----
> 
> /trunk/KDE/kdegames/kiriki/src/diceswidget.h 1119312 
> /trunk/KDE/kdegames/kiriki/src/diceswidget.cpp 1119312 
> /trunk/KDE/kdegames/kiriki/src/kiriki.h 1119312 
> /trunk/KDE/kdegames/kiriki/src/kiriki.cpp 1119312 
> /trunk/KDE/kdegames/kiriki/src/lateralwidget.h 1119312 
> /trunk/KDE/kdegames/kiriki/src/lateralwidget.cpp 1119312 
> /trunk/KDE/kdegames/kiriki/src/scores.h 1119312 
> /trunk/KDE/kdegames/kiriki/src/scores.cpp 1119312 
> 
> Diff: http://reviewboard.kde.org/r/3793/diff
> 
> 
> Testing
> -------
> 
> 
> Thanks,
> 
> Luiz Romário
> 
> 

_______________________________________________
kde-games-devel mailing list
kde-games-devel@kde.org
https://mail.kde.org/mailman/listinfo/kde-games-devel


[prev in list] [next in list] [prev in thread] [next in thread] 

Configure | About | News | Add a list | Sponsored by KoreLogic