[prev in list] [next in list] [prev in thread] [next in thread] 

List:       kde-devel
Subject:    Kate config dialog: simplified
From:       "=?UTF-8?Q?Rafael_Fern=C3=A1ndez_L=C3=B3pez?=" <ereslibre () gmail ! com>
Date:       2007-06-06 22:05:22
Message-ID: 93f85fee0706061505l4f8bcad2wff6d2aa100692514 () mail ! gmail ! com
[Download RAW message or body]

[Attachment #2 (multipart/alternative)]

[Attachment #4 (text/plain)]

Hi,

I have been working this time on the issue that somebody pointed out at
kde-usability. Since I consider a must hearing our users, and thus, making
life easier to them (I'm not saying Kate is hard or anything, it rocks). I
didn't a really option refactoring, because I think we shouldn't get out
Kate's possibilities, an editor like Kate needs lots of options, because of
its powerful, and I don't disagree with that. What's true is that the first
config dialog seemed sometimes a bit repetitive, and some groups could be
merged. That is what I did.

The way I did it... well probably is not the best, but for sure it will work
for 4.0, and is easy to work out for 4.1. The idea is, on the dialogs that
were merged, for example: Cursor&Selection, Editor, Indenting. I left the
original "Editor" and it is built on the first tab, but what I did is
directly construct objects for the cursor&selection dialog and identing
dialog. When apply() is called for "Editor", it calls to those methods on
respective objects. We only need to get out "Editor", "Open/Save", and
"Plugins". If we move them out of the main class that creates each tab
widget, we are done. It is easy, and consistent. The result will be, for
example, instead of this:

.....SaveDialog....:apply()
{
    modeDialog->apply();

    iDoMyThings();
    iAmSavingMyInformation();
    becauseIAmTheSaveDialog();
    butIDontKnowModeDialogIsHereToo();
}

we would have:

.....SaveModeDialog....:apply() // Probably a better name, is not the
important thing now
{
    modeDialog->apply();
    saveDialog->apply();
}

So here you can find a video showing how it looks:
http://media.ereslibre.es/2007/06/katesimplifiedconfigdialog.mpeg

And here you can find the patch:
http://media.ereslibre.es/2007/06/katesimplifiedconfigdialog.diff


Bye and thanks,
Rafael Fernández López.

[Attachment #5 (text/html)]

Hi,<br><br>I have been working this time on the issue that somebody pointed out at \
kde-usability. Since I consider a must hearing our users, and thus, making life easier to them \
(I&#39;m not saying Kate is hard or anything, it rocks). I didn&#39;t a really option \
refactoring, because I think we shouldn&#39;t get out Kate&#39;s possibilities, an editor like \
Kate needs lots of options, because of its powerful, and I don&#39;t disagree with that. \
What&#39;s true is that the first config dialog seemed sometimes a bit repetitive, and some \
groups could be merged. That is what I did. <br><br>The way I did it... well probably is not \
the best, but for sure it will work for 4.0, and is easy to work out for 4.1. The idea is, on \
the dialogs that were merged, for example: Cursor&amp;Selection, Editor, Indenting. I left the \
original &quot;Editor&quot; and it is built on the first tab, but what I did is directly \
construct objects for the cursor&amp;selection dialog and identing dialog. When apply() is \
called for &quot;Editor&quot;, it calls to those methods on respective objects. We only need to \
get out &quot;Editor&quot;, &quot;Open/Save&quot;, and &quot;Plugins&quot;. If we move them out \
of the main class that creates each tab widget, we are done. It is easy, and consistent. The \
result will be, for example, instead of this: \
<br><br>.....SaveDialog....:apply()<br>{<br>&nbsp;&nbsp;&nbsp; \
modeDialog-&gt;apply();<br><br>&nbsp;&nbsp;&nbsp; iDoMyThings();<br>&nbsp;&nbsp;&nbsp; \
iAmSavingMyInformation();<br>&nbsp;&nbsp;&nbsp; \
becauseIAmTheSaveDialog();<br>&nbsp;&nbsp;&nbsp; \
butIDontKnowModeDialogIsHereToo();<br>}<br><br>we would have: \
<br><br>.....SaveModeDialog....:apply() // Probably a better name, is not the important thing \
now<br>{<br>&nbsp;&nbsp;&nbsp; modeDialog-&gt;apply();<br>&nbsp;&nbsp;&nbsp; \
saveDialog-&gt;apply();<br>}<br><br>So here you can find a video showing how it looks: \
<br><span id="_user_dhdev@gmx.de" style="color: rgb(91, 16, 148);"><a \
href="http://media.ereslibre.es/2007/06/katesimplifiedconfigdialog.mpeg">http://media.ereslibre.es/2007/06/katesimplifiedconfigdialog.mpeg</a><br \
clear="all"> </span><br>And here you can find the patch:<br><a \
href="http://media.ereslibre.es/2007/06/katesimplifiedconfigdialog.diff">http://media.ereslibre.es/2007/06/katesimplifiedconfigdialog.diff</a><br><br><br>Bye \
and thanks,<br> Rafael Fernández López.



>> Visit http://mail.kde.org/mailman/listinfo/kde-devel#unsub to unsubscribe <<


[prev in list] [next in list] [prev in thread] [next in thread] 

Configure | About | News | Add a list | Sponsored by KoreLogic