[prev in list] [next in list] [prev in thread] [next in thread] 

List:       kde-core-devel
Subject:    Re: Review Request: Displaying Job Progress in Icons - Review Request
From:       "Shaun Reich" <shaun.reich () kdemail ! net>
Date:       2010-02-14 6:28:56
Message-ID: 20100214062856.4712.91406 () localhost
[Download RAW message or body]


-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
http://reviewboard.kde.org/r/2057/
-----------------------------------------------------------

(Updated 2010-02-14 06:28:50.684058)


Review request for kdelibs.


Changes
-------

Fixes all aforementioned issues and a couple(minors) that I have found. I had to omit \
files: joburlcache* and org.kde.kuiserver.xml from diff. I also could only place this \
diff on /kio/kio, I see the review mentions removals of stuff outside of that path; \
ignore them, as they are impossible and non-applicable. I have fixed the issues \
outside of that path though, including debrutalizing Rafael's name ;-)

P.S. This took a lot of work just to get the diff to upload. Apparently I have found \
a bug in reviewboard, but it looks like I may have found a way to fix it too (or a \
way around it - whichever.


Summary
-------

Hello,

This merge request is for the changes I have done (on my branch), along with other \
changes(but those are just waiting for this review).

The branch was for a project that I have done; displaying the job progress on the \
file/folder icons. It essentially shows the status, as in whether or not there is a \
job being performed on a certain dest. url, if there is, a download icon will be \
shown at the corner, with an animation(circles rotating around a focal point), to \
show that a transfer is happening (download, copy, etc..). 

It should be pretty subtle, but may need some tweaking.


I don't really like the KDirModel::setDisplayJobTransfers(bool), and \
KFileItemDelegate::setDisplayJobTranfers(bool). They sound terrible imo, and seem to \
go against Nice API Design, but I use them for lack of a better name. Hopefully you \
guys have some suggestions?

Naturally those 2 method properties are off by default, the individual apps should \
turn it on at their discretion. I will probably do that for Dolphin and the \
Folderview plasmoid.


There was some oddity that I experienced, that seemed like an impossibility (then \
again, lots of bugs do). It wouldn't stop displaying that a job was happening, but I \
tracked it down and if anything it would have been the sender (kuiserver)'s issue. \
But I've tested kuiserver quite rigorously...I'm thinking it is just some problem \
dealing with the *major* version differences I am running.. *shrug*


I can no longer test this branch with my system, as I run trunk and running this \
really old checkout side by side...well, that was a pain I am not going to go through \
again, as apps were crashing so often etc.. and I *still* don't have my plasma's \
desktop activities back up and running, only 2 system monitors on the desktop :)


Once it's committed to trunk, I should be able to quickly verify and track down any \
issues...


Diffs (updated)
-----

  /trunk/KDE/kdelibs/kio/kio/kfileitemdelegate.cpp 1089795 
  /trunk/KDE/kdelibs/kio/kio/kfileitemdelegate.h 1089795 
  /trunk/KDE/kdelibs/kio/kio/kdirmodel.cpp 1089795 
  /trunk/KDE/kdelibs/kio/kio/copyjob.cpp 1089795 
  /trunk/KDE/kdelibs/kio/kio/delegateanimationhandler.cpp 1089795 
  /trunk/KDE/kdelibs/kio/kio/delegateanimationhandler_p.h 1089795 
  /trunk/KDE/kdelibs/kio/kio/job.cpp 1089795 
  /trunk/KDE/kdelibs/kio/kio/kdirmodel.h 1089795 

Diff: http://reviewboard.kde.org/r/2057/diff


Testing
-------

oodles.


Thanks,

Shaun


[prev in list] [next in list] [prev in thread] [next in thread] 

Configure | About | News | Add a list | Sponsored by KoreLogic