Hello Waldo, On Thu, 25 Nov 2004, Waldo Bastian wrote: > Proposed DCOP interface > ======================= > > enumOnlineStatus { Unknown = 0, OffLine = 1, Online = 2 } > > enumOnlineStatus (int?) onlineStatus() > // Returns internet status, can be used by applications such as KMail / > // KWeather in deciding whether to do certain background activities > > void setOnlineStatus(enumOnlineStatus (int?) ) What if there are multiple ways to connect to the Internet? Somehow the notion of a "profile" would be nice where a different connection would be used depending whether you are at home (LAN, DSL etc.) or travelling (cell phone etc). > // Sets internet status, to be used by kppp / kisdn or distribution specific > // tools > > signal onlineStatusChanged(enumOnlineStatus (int?) ) > // DCOP signal that gets emited whenever the onlineStatus changes If you look at the signals of KpppIface you'll notice 4 different once: void aboutToConnect(); void connected(); void aboutToDisconnect(); void disconnected(); So it might be useful to have both pre and post signals for triggering certain actions. Whether that should be crammed into the enum or in additional signals I don't know. > setNetworkActivationCallback(DCOPRef, function) > // Specify DCOP function that should be called in order to request activation > // of network > // To be used by kppp / kisdn or distribution specific tools Or is this the one you meant to (partially) achieve the purpose depicted above? Thanks for getting this going, Harri.