On Jeudi 1 Novembre 2001 08:45, Charles Samuels wrote: > This makes it compatible with old version, except for a few small things. > > - some methods (like getKey) now have a group argument > - it's `QString defaultGroup() const` instead of `QString group() const` Which breaks code again.... Why not simply have KConfigGroup group(const QString &_group) const (the new one) and QString group() const; (the old one) ? I don't see a conflict here. Furthermore, defaultGroup is a bad naming IMHO (could have been "currentGroup", but there's no point in changing the old API, the goal is to implement a new one which doesn't have that notion ;) I see you added a KConfigGroup group() const that returns the KConfigGroup for the "current group" ... but I don't see the point in that one. It's a mixture of the old way and the new way, so it's quite useless IMHO. If you remove it, you'll be able to rename defaultGroup() back to group(), so that the old source still compiles (I guess there is quite some code that does KConfigGroupSaver's job manually, so it's important that group() still works). Other than that, this looks quite good to me. Good job! > Of course I expect an immediate response from David :) :) I'm going away for a few days, so don't expect much from me in the next few days. David.