[prev in list] [next in list] [prev in thread] [next in thread] 

List:       kde-core-devel
Subject:    Re: [PATCH] k_dcop_signalsj
From:       Simon Hausmann <hausmann () kde ! org>
Date:       2001-10-01 21:36:26
[Download RAW message or body]

On Mon, Oct 01, 2001 at 02:22:53PM -0700, Waldo Bastian wrote:
> On Monday 01 October 2001 02:13 pm, Alexander Kellett wrote:
> > On Mon, Oct 01, 2001 at 08:37:06PM +0200, Malte Starostik wrote:
> > > Assuming the enum is DCOPClient::ExcludeSelfEnum (don't actually do that!
> > > :), maybe you could add an argument
> > > DCOPClient::ExcludeSelfEnum excludeSelf = DCOPClient::DontExcludeSelf
> > > to every signal.
> >
> > This would cause big problems with functions with default parameters -
> > which i plan to add soon to dcopidl ;-)
> >
> > Well, for the moment tronical has solved the problem with a simple
> > change in kbookmarklistener's design.
> >
> > But, anyone else think that excludeSelf would be useful?
> 
> Maybe you can put it in the "connect" function. That would actually be the 
> logical place for it, wouldn't it?

Isn't it even more logical then to not connect at all? ;-) 
I mean...if I write

connectDCOPSignal( senderAppId, senderObj, "mySignal", receiverId, receiverObj, 
                   DCOPClient::ExcludeSelf )

isn't it more readable to write:

if ( senderAppId != receiverId )
    connectDCOPSignal( ... )

I find the first one a bit confusing :)

Simon

[prev in list] [next in list] [prev in thread] [next in thread] 

Configure | About | News | Add a list | Sponsored by KoreLogic