[prev in list] [next in list] [prev in thread] [next in thread] 

List:       jakarta-commons-dev
Subject:    [jira] [Commented] (MATH-1597) Low-discrepancy sequence
From:       "Gilles Sadowski (Jira)" <jira () apache ! org>
Date:       2021-05-31 23:11:00
Message-ID: JIRA.13381175.1622421296000.531411.1622502660083 () Atlassian ! JIRA
[Download RAW message or body]


    [ https://issues.apache.org/jira/browse/MATH-1597?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=17354677#comment-17354677 \
] 

Gilles Sadowski commented on MATH-1597:
---------------------------------------

Thanks for the proposal.
This should however be discussed first on the "dev" ML (please reply to my post over \
there).

bq. I added the SkippableSequence after looking at JumpableUniformRandomProvider

My  suggestion was for "skip" to be similar to "jump" (i.e. it would return a \
"SkippableSequence")...

> Low-discrepancy sequence
> ------------------------
> 
> Key: MATH-1597
> URL: https://issues.apache.org/jira/browse/MATH-1597
> Project: Commons Math
> Issue Type: Sub-task
> Reporter: Gilles Sadowski
> Priority: Minor
> Fix For: 4.0
> 
> Time Spent: 10m
> Remaining Estimate: 0h
> 
> Two low-discrepancy sequences are implemented in Commons Math (in package \
>                 {{o.a.c.math4.legacy.random}}:
> * {{SobolSequenceGenerator}}
> * {{HaltonSequenceGenerator}}
> They both provide several methods:
> * {{nextVector()}}
> * {{skipTo(int)}}
> * {{getNextIndex()}}
> of which only the first is part of their common API through the \
> {{RandomVectorGenerator}}. I propose to create an interface that would better \
> represent the specific concept (and avoid the confusion with pseudo-random \
> generators): {code}
> public interface LowDiscrepancySequence extends Supplier<double[]> { /* ... */}
> {code}
> Thus, instead of class {{SobolSequenceGenerator}} we'd have:
> {code}
> public class SobolSequence implements LowDiscrepancySequence {
> // ...
> }
> {code}
> This functionality could be moved to a new {{o.a.c.m.legacy.quasirandom}} package \
> (?). Method {{skipTo}} could be replaced with an API similar to Commons RNG \
> {{JumpableUniformRandomProvider}} (?).



--
This message was sent by Atlassian Jira
(v8.3.4#803005)


[prev in list] [next in list] [prev in thread] [next in thread] 

Configure | About | News | Add a list | Sponsored by KoreLogic