[prev in list] [next in list] [prev in thread] [next in thread] 

List:       darcs-devel
Subject:    [darcs-devel] darcs patch: Lessen the scare factor in 'darcs send'
From:       zander () kde ! org
Date:       2005-01-08 13:52:15
Message-ID: E1CnH0p-0001Ps-R5 () abridgegame ! org
[Download RAW message or body]

Sat Jan  8 14:50:28 CET 2005  zander@kde.org
  * Lessen the scare factor in 'darcs send' which said: 'Sending by email t=
o'
  after which it started asking for user-permission, while the initial mess=
age
  gave the impression it would not.
  Now it says: 'Found email to send to a@b.com'

[Attachment #3 (text/x-darcs-patch)]

New patches:

[Lessen the scare factor in 'darcs send' which said: 'Sending by email to'
zander@kde.org**20050108135028
 after which it started asking for user-permission, while the initial messa=
ge
 gave the impression it would not.
 Now it says: 'Found email to send to a@b.com'
] {
hunk ./Send.lhs 208
-               emails -> do putInfoLn $ "Sending by email to "++unwords em=
ails
+               emails -> do putInfoLn $ "Found email to send to "++unwords=
 emails
}

Context:

[do not use `-e' as a short form of --set-scripts-executable option
Karel Gardas <kgardas@objectsecurity.com>**20050102190722] =

[enhance `pull' command to support --set/dont-set-scripts-executable option=
s
Karel Gardas <kgardas@objectsecurity.com>**20050101223751] =

[enhance `apply' command to support --set/dont-set-scripts-executable optio=
ns
Karel Gardas <kgardas@objectsecurity.com>**20050101223645] =

[fix syntax errors in my last doc patch that prevented darcs from compiling=
.
Mark Stosberg <mark@summersault.com>**20050101192840] =

[clarify annotate docs
Mark Stosberg <mark@summersault.com>**20041231153708
 =

 I think a primary reason that annotate has been confusing is because it is
 documented as provided 'useful information'. This is too vague to be usefu=
l
 information. :)
 =

 So I tried to figure out exactly what annotate does do, and be explicit
 in the documentation about that.
 =

 I was a little surprised that annotate didn't have a line number option.
 It seems it already has the ability to report when a specific line was las=
t changed. =

 =

 If this were to be implemented, it would be nice to support relative and a=
bsolute line ranges,
 so you could express: "Report on lines within 10 lines from here".
] =

[replace `if' with `when' to improve readability in my recent slurp changes
Karel Gardas <kgardas@objectsecurity.com>**20041230222254] =

[remove some GHC 6.0.3 compatibility #ifdefs
Karel Gardas <kgardas@objectsecurity.com>**20041230203913] =

[make darcs changes --context support --to-patch, etc
Anthony Towns <aj@azure.humbug.org.au>**20041222203754] =

[rename 'unix script to 'script' in Karel's patch
Mark Stosberg <mark@summersault.com>**20041229224115] =

[enhance `get' command to support --set/donot-set-unix-scripts-executable o=
ptions
Karel Gardas <kgardas@objectsecurity.com>**20041228222948] =

[enhance slurp write related and repository apply_patches functions to supp=
ort executable scripts
Karel Gardas <kgardas@objectsecurity.com>**20041228212713
 This patch enhances slurp write related functions and repository
 apply_patches function to make Unix scripts executable if appropriate
 -e/--set-unix-scripts-executable option is used.
] =

[add --set-unix-scripts-executable and --donot-set-unix-scripts-executable =
options support
Karel Gardas <kgardas@objectsecurity.com>**20041228123330] =

[add FileSystem module with basic implementation of make_executable functio=
n
Karel Gardas <kgardas@objectsecurity.com>**20041228114555
 This patch adds FileSystem module which is intended to provide various
 file system related functions and hide under-laying OS
 functionality. Currently only `make_executable' function is provided
 which makes file executable for its owner and owner group on
 Unix(-like) OSes and does nothing on Win32 OSes.
] =

[revert nice error message on patch parsing.
David Roundy <droundy@abridgegame.org>**20041229153258
 The problem was that darcs tries parsing patch bundles different ways to
 see whether it's been mime-encoded or not, and failing with errorDoc rathe=
r
 than by returning Nothing breaks that.  If we want nicer messages for pars=
e
 errors, we should switch from Maybe (Patch, PackedString) to Either Doc
 (Patch, PackedString).
] =

[add configure option to fix path to sendmail even if it's not present.
David Roundy <droundy@abridgegame.org>**20041229151244] =

[Add RSS feed of latest repo changes to darcs.net homepage.
Mark Stosberg <mark@summersault.com>**20041229004651
 =

 A temporary preview of this is here:
 http://mark.stosberg.com/Tech/darcs/front.html
 =

 David suggested it would be desirable to also have the author's
 named displayed. That appears to be possible because that information =

 is in the feed in an <author> tag. However, I don't have the patience
 to make that work tonight. If someone else wants to, feel free.
 =

] =

[bash completion made more robust regarding shell special chars
Guillaume Outters <guillaume.outters@free.fr>**20041228231448
 IFS set to CR, for correct spliting of darcs --list-option entries contain=
ing spaces.
 We escape all special characters using printf %q, so that the shell passes=
 us our parameters back as we want them.
] =

[avoid duplicated code in commute and commute_no_merger.
David Roundy <droundy@abridgegame.org>**20041222142807] =

[Reorganize breakup of Patch to avoid circular dependencies.
David Roundy <droundy@abridgegame.org>**20041221141512] =

[resolve conflict with whitespace change.
David Roundy <droundy@abridgegame.org>**20041221130035] =

[Rejig patch headings so documentation makes some sense again
Ian Lynagh <igloo@earth.li>**20041217174449] =

[Merge changes
Ian Lynagh <igloo@earth.li>**20041217165950] =

[Split Patch up more. Unfortunately needs a .hi-boot file.
Ian Lynagh <igloo@earth.li>**20041211024030] =

[disallow accidently pushing to the current repo
Mark Stosberg <mark@summersault.com>**20041219172359] =

[Test for pulling from current repo before setting it as the default
Mark Stosberg <mark@summersault.com>**20041219171533] =

[Some more tests for push. =

Mark Stosberg <mark@summersault.com>**20041219163241] =

[provide better stripCr implementation
Will <will@glozer.net>**20041219031418] =

[add konquerer workaround to cgi annotate
Will <will@glozer.net>**20041219024435] =

[use fail when possible for errors.
David Roundy <droundy@abridgegame.org>**20041218153234] =

[address #114 - provide a better error when you accidently try to pull from=
 yourself
Mark Stosberg <mark@summersault.com>**20041218025451
 =

 This was my first real experiment with Haskell, so someone who knows bette=
r
 will probably want to rewrite it. :) =

 =

 Also, this only addresses the 'pull' case. It may be better put this logic=
 in a
 shared routine, so it be used by 'push' and elsewhere.  =

] =

[remove trailing whitespace
simons@cryp.to**20041218004144] =

[don't import type 'Patch' twice
simons@cryp.to**20041218004106] =

[remove duplicate imports (error in ghc-6.3)
simons@cryp.to**20041218002402] =

[avoid conflicts by importing only 'bug' from DarcsUtils
simons@cryp.to**20041218002301] =

[Fix manual to state 'darcs get' has --tag, not --tag-name
zander@kde.org**20041217153547] =

[strip trailing CR in pref files
Will <will@glozer.net>**20041216073907] =

[fix typo in mingw reference
Lode Leroy <lode_leroy@hotmail.com>**20041202131840] =

[fix bug that left junk equal to identity patch in pending.
David Roundy <droundy@abridgegame.org>**20041215134337] =

[typo fix
Mark Stosberg <mark@summersault.com>**20041215023027] =

[removing Amending patches from basic documentation
Mark Stosberg <mark@summersault.com>**20041106030942
 =

 I really like this clear description of what Amend record is actually doin=
g.
 I've submitted a patch to the stable repo to merge some of the wording her=
e
 into the (currently sparse) docs for admend-record.
 =

 Amend-record is a more advanced, dangerous command which doesn't belong in=
 a
 "Basics" section, so I removed it here.
] =

[improve documentation clarity
Mark Stosberg <mark@summersault.com>**20041106030733] =

[improve formatting of 'working' and 'current'
Mark Stosberg <mark@summersault.com>**20041106030657] =

[documentation, basics on creating patches
Tommy Pettersson <ptp@lysator.liu.se>**20041103111151] =

[update webpage to say 1.0.1 is latest stable source now.
David Roundy <droundy@abridgegame.org>**20041214134854] =

[TAG 1.0.1
David Roundy <droundy@abridgegame.org>**20041214131758] =

Patch bundle hash:
74d6bb8308ba9fa57fd5f3d68b4fcb9907efa9d9

.

[prev in list] [next in list] [prev in thread] [next in thread] 

Configure | About | News | Add a list | Sponsored by KoreLogic