[prev in list] [next in list] [prev in thread] [next in thread] 

List:       calligra-devel
Subject:    Re: Review Request: Implement saving for the KoUnavailShape
From:       "Inge Wallin" <inge () lysator ! liu ! se>
Date:       2011-04-01 15:44:15
Message-ID: 20110401154415.20769.27376 () vidsolbach ! de
[Download RAW message or body]

[Attachment #2 (multipart/alternative)]


-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
http://git.reviewboard.kde.org/r/100629/
-----------------------------------------------------------

(Updated April 1, 2011, 3:44 p.m.)


Review request for Calligra.


Changes
-------

Here is version 3 of the diff. I implemented all comments, and also removed=
 everything that's not the core change.

I know also know why OOo doesn't like the files that I write.  Apparently, =
OOo needs embedded objects to be called "Object<num>"; UObject<num> is not =
good.  This is contrary to the spec, that says that objects could be named =
anything.  If this diff is Ok'ed, I will go through all the source code of =
Calligra and make sure that all objects are named through calls to getFileN=
ame() and not created ad hoc.  Right now, I can't call the objects Object<n=
um> since that may create collisions with objects created by other parts of=
 Calligra. Then OOo will also be able to read our files.


Summary
-------

This patch implements saving in the KoUnavailShape.

The method it uses is to introduce a new class, KoEmbeddedFileSaver, in koo=
df. This class is a bit like the KoEmbeddedObjectSaver class, and is create=
d and instantiated in the same places. It is also part of the KoShapeSaving=
Context.

As a bonus, this patch also implements saving for the Vector shape, since I=
 used that for testing in early stages.


Diffs (updated)
-----

  libs/odf/KoOdfManifest.h PRE-CREATION =

  libs/odf/KoOdfLoadingContext.h 023b92f =

  libs/odf/KoOdfLoadingContext.cpp ce53992 =

  libs/odf/CMakeLists.txt 668ba51 =

  libs/odf/KoEmbeddedDocumentSaver.h 11cf075 =

  libs/odf/KoEmbeddedDocumentSaver.cpp a8e13d8 =

  libs/flake/KoUnavailShape.cpp 3f10acf =

  libs/odf/KoOdfManifest.cpp PRE-CREATION =

  plugins/vectorshape/VectorShape.cpp 3229341 =


Diff: http://git.reviewboard.kde.org/r/100629/diff


Testing
-------

Tested with a simple odt file with an embedded spreadsheet.


Thanks,

Inge


[Attachment #5 (text/html)]

<html>
 <body>
  <div style="font-family: Verdana, Arial, Helvetica, Sans-Serif;">
   <table bgcolor="#f9f3c9" width="100%" cellpadding="8" style="border: 1px #c9c399 \
solid;">  <tr>
     <td>
      This is an automatically generated e-mail. To reply, visit:
      <a href="http://git.reviewboard.kde.org/r/100629/">http://git.reviewboard.kde.org/r/100629/</a>
  </td>
    </tr>
   </table>
   <br />


<table bgcolor="#fefadf" width="100%" cellspacing="0" cellpadding="8" \
style="background-image: \
url('http://git.reviewboard.kde.orgrb/images/review_request_box_top_bg.png'); \
background-position: left top; background-repeat: repeat-x; border: 1px black \
solid;">  <tr>
  <td>

<div>Review request for Calligra.</div>
<div>By Inge Wallin.</div>


<p style="color: grey;"><i>Updated April 1, 2011, 3:44 p.m.</i></p>



<h1 style="color: #575012; font-size: 10pt; margin-top: 1.5em;">Changes</h1>
<table width="100%" bgcolor="#ffffff" cellspacing="0" cellpadding="10" style="border: \
1px solid #b8b5a0">  <tr>
  <td>
   <pre style="margin: 0; padding: 0; white-space: pre-wrap; white-space: \
-moz-pre-wrap; white-space: -pre-wrap; white-space: -o-pre-wrap; word-wrap: \
break-word;">Here is version 3 of the diff. I implemented all comments, and also \
removed everything that&#39;s not the core change.

I know also know why OOo doesn&#39;t like the files that I write.  Apparently, OOo \
needs embedded objects to be called &quot;Object&lt;num&gt;&quot;; UObject&lt;num&gt; \
is not good.  This is contrary to the spec, that says that objects could be named \
anything.  If this diff is Ok&#39;ed, I will go through all the source code of \
Calligra and make sure that all objects are named through calls to getFileName() and \
not created ad hoc.  Right now, I can&#39;t call the objects Object&lt;num&gt; since \
that may create collisions with objects created by other parts of Calligra. Then OOo \
will also be able to read our files.</pre>  </td>
 </tr>
</table>


<h1 style="color: #575012; font-size: 10pt; margin-top: 1.5em;">Description </h1>
<table width="100%" bgcolor="#ffffff" cellspacing="0" cellpadding="10" style="border: \
1px solid #b8b5a0">  <tr>
  <td>
   <pre style="margin: 0; padding: 0; white-space: pre-wrap; white-space: \
-moz-pre-wrap; white-space: -pre-wrap; white-space: -o-pre-wrap; word-wrap: \
break-word;">This patch implements saving in the KoUnavailShape.

The method it uses is to introduce a new class, KoEmbeddedFileSaver, in koodf. This \
class is a bit like the KoEmbeddedObjectSaver class, and is created and instantiated \
in the same places. It is also part of the KoShapeSavingContext.

As a bonus, this patch also implements saving for the Vector shape, since I used that \
for testing in early stages.</pre>  </td>
 </tr>
</table>


<h1 style="color: #575012; font-size: 10pt; margin-top: 1.5em;">Testing </h1>
<table width="100%" bgcolor="#ffffff" cellspacing="0" cellpadding="10" style="border: \
1px solid #b8b5a0">  <tr>
  <td>
   <pre style="margin: 0; padding: 0; white-space: pre-wrap; white-space: \
-moz-pre-wrap; white-space: -pre-wrap; white-space: -o-pre-wrap; word-wrap: \
break-word;">Tested with a simple odt file with an embedded spreadsheet.</pre>  </td>
 </tr>
</table>




<h1 style="color: #575012; font-size: 10pt; margin-top: 1.5em;">Diffs</b> \
(updated)</h1> <ul style="margin-left: 3em; padding-left: 0;">

 <li>libs/odf/KoOdfManifest.h <span style="color: grey">(PRE-CREATION)</span></li>

 <li>libs/odf/KoOdfLoadingContext.h <span style="color: grey">(023b92f)</span></li>

 <li>libs/odf/KoOdfLoadingContext.cpp <span style="color: grey">(ce53992)</span></li>

 <li>libs/odf/CMakeLists.txt <span style="color: grey">(668ba51)</span></li>

 <li>libs/odf/KoEmbeddedDocumentSaver.h <span style="color: \
grey">(11cf075)</span></li>

 <li>libs/odf/KoEmbeddedDocumentSaver.cpp <span style="color: \
grey">(a8e13d8)</span></li>

 <li>libs/flake/KoUnavailShape.cpp <span style="color: grey">(3f10acf)</span></li>

 <li>libs/odf/KoOdfManifest.cpp <span style="color: grey">(PRE-CREATION)</span></li>

 <li>plugins/vectorshape/VectorShape.cpp <span style="color: \
grey">(3229341)</span></li>

</ul>

<p><a href="http://git.reviewboard.kde.org/r/100629/diff/" style="margin-left: \
3em;">View Diff</a></p>




  </td>
 </tr>
</table>




  </div>
 </body>
</html>



_______________________________________________
calligra-devel mailing list
calligra-devel@kde.org
https://mail.kde.org/mailman/listinfo/calligra-devel


[prev in list] [next in list] [prev in thread] [next in thread] 

Configure | About | News | Add a list | Sponsored by KoreLogic