[prev in list] [next in list] [prev in thread] [next in thread] 

List:       apache-stdcxx-dev
Subject:    [jira] Commented: (STDCXX-395) Make _RWSTD_WCHAR_T_MIN/MAX names
From:       "Martin Sebor (JIRA)" <jira () apache ! org>
Date:       2007-04-11 21:55:32
Message-ID: 12218800.1176328532259.JavaMail.jira () brutus
[Download RAW message or body]


    [ https://issues.apache.org/jira/browse/STDCXX-395?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel#action_12488201 \
] 

Martin Sebor commented on STDCXX-395:
-------------------------------------

It would be easy to make this change and bring the names of these two macros into \
harmony with the corresponding libc counterparts (WCHAR_MIN and WCHAR_MAX). IMO, it \
would even be an improvement. If you submit a patch and there are no objections to it \
from anyone I'll apply it, just as long as it's understood that the macros are \
internal to stdcxx and not to be used or in any way relied on by user programs.

> Make _RWSTD_WCHAR_T_MIN/MAX names consistent with other *_MIN/MAX names.
> ------------------------------------------------------------------------
> 
> Key: STDCXX-395
> URL: https://issues.apache.org/jira/browse/STDCXX-395
> Project: C++ Standard Library
> Issue Type: Improvement
> Components: Configuration
> Affects Versions: 4.1.3
> Reporter: Eric Lemings
> Priority: Minor
> Fix For: 4.1.4
> 
> 
> There are numerous MIN/MAX variables defined during configuration.
> #define _RWSTD_DBL_MAX          1.7976931348623157e+308
> #define _RWSTD_FLT_MAX          3.40282347e+38F
> #define _RWSTD_LDBL_MAX         1.18973149535723176502e+4932L
> #define _RWSTD_BOOL_MAX    !0
> #define _RWSTD_CHAR_MAX    '\x7f'
> #define _RWSTD_CHAR_MIN    (-_RWSTD_CHAR_MAX - 1)
> #define _RWSTD_SCHAR_MAX   0x7f
> #define _RWSTD_SCHAR_MIN   (-_RWSTD_SCHAR_MAX - 1)
> #define _RWSTD_UCHAR_MAX   0xffU
> #define _RWSTD_SHRT_MAX    0x7fff
> #define _RWSTD_SHRT_MIN    (-_RWSTD_SHRT_MAX - 1)
> #define _RWSTD_USHRT_MAX   0xffffU
> #define _RWSTD_INT_MAX     0x7fffffff
> #define _RWSTD_INT_MIN     (-_RWSTD_INT_MAX - 1)
> #define _RWSTD_UINT_MAX    0xffffffffU
> #define _RWSTD_LONG_MAX    0x7fffffffffffffffL
> #define _RWSTD_LONG_MIN    (-_RWSTD_LONG_MAX - 1L)
> #define _RWSTD_ULONG_MAX   0xffffffffffffffffUL
> #define _RWSTD_LLONG_MAX   0x7fffffffffffffffLL
> #define _RWSTD_LLONG_MIN   (-_RWSTD_LLONG_MAX - 1LL)
> #define _RWSTD_ULLONG_MAX  0xffffffffffffffffULL
> #define _RWSTD_WCHAR_T_MAX 0x7fffffff
> #define _RWSTD_WCHAR_T_MIN  (-_RWSTD_WCHAR_T_MAX - 1)
> #define _RWSTD_MB_LEN_MAX    16   /* libc value */
> #define _RWSTD_LC_MAX               _RWSTD_LC_IDENTIFICATION
> #define _RWSTD_SIZE_MAX       _RWSTD_ULONG_MAX
> #define _RWSTD_PTRDIFF_MAX    _RWSTD_LONG_MAX
> #define _RWSTD_RAND_MAX       2147483647
> #define _RWSTD_FOPEN_MAX      16
> #define _RWSTD_FILENAME_MAX   4096
> #define _RWSTD_TMP_MAX        238328
> #define _RWSTD_SIG_ATOMIC_MAX _RWSTD_INT_MAX
> #define _RWSTD_WINT_MAX _RWSTD_UINT_MAX
> Several of the types covered by these variables use the C naming convention by \
> adding "_t" to the type name (e.g. sig_atomic_t, wint_t, ptrdiff_t) but only \
> _RWSTD_WCHAR_T_MIN/MAX has this suffix in the variable name itself.  Request making \
> this variable name consistent with the others.  (Why?  It makes GNU Automake build \
> support that I'm working on much simpler.)

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


[prev in list] [next in list] [prev in thread] [next in thread] 

Configure | About | News | Add a list | Sponsored by KoreLogic